Ford Mustang Forum banner

altenator

  1. 5.0L Tech
    Okay im considering buying a 3g or 6g one wire alt. what is required? besides the bracket modifycation. I found several forum posts but none for my car. The issue Im haveing now is the car runs but does not charge the batt. If I leave it running for 40 mins and try to roll up the window it...
  2. 5.0L Tech
    OKay so I have this issue where the car will start run but not charge the battery. sometimes I will get a few starts before the battery is dead. unless I let it runn for 40 mins then if I attempt to roll up a window. it will stall. I get an odd idle after the battery is drained. but the car...
  3. 5.0L Tech
    Okay so I charge the battery with my jeep. it runs good for awhile.. it wont stall by itself After about 15-20 mins if I try to roll up my window it will stall. but it drains the battery until its dead. will keep itself running just wont charge the battery. will run like crap. I took out the...
  4. V6 Tech
    About two weeks ago, I was on my way to work when I noticed the accent lights/instrument cluster inside my car were dimming and my battery gauge was going from normal to low, then bounced back to normal when I revved the car. I figured it was the battery and purchased a new battery. Everything...
  5. 4.6L Tech
    Replaced engines to a '96 from a '97. battery light came on. Checked battery and alt. even swapped alternators and same thing. then i swaped wire harness's with one I know is good, same outcome. checked and rechecked every connecton in engine compartment. problem is, I bought the '96 with a...
  6. 5.0L Tech
    Hey guys I have an 87 5.0 and recently it seems something has been draining my battery. I unhooked my ground cable to the battery and it didnt die, but when I hooked it back up and took off the power cable my car died. Does that mean that my altenator is bad? It all started when I put an amp and...
  7. 2005-2010 Mustang GT Tech
    Gentlemen, I am new to posting to the site, but I have read through a few of the threads. I am in need of some big time help. Here is my problem. I have a 2005 4.6 GT. My car starts fine always on the first turn. I proceed to work. While approaching a stop light or anything that requires me to...
  8. 2005-2010 V6 Mustang Tech
    Hi guys, today i replaced my tail light bulbs and started my car and everything was fine. 5 minutes later I turn on my car to park it on the street and my car started and right away it started to idle high and low then a few seconds later it just turned off. A few months ago i got a new...
  9. 4.6L Tech
    Hey guys i just put a set of march underdrive pullys on my 03 gt and eversince then when i shut my car off and try to re start it the Battery is dead. I dont idle alot so im wondering if anyone has a solution or something to help me out or is there some sort of alternator i can buy.. p.s the...
  10. 5.0L Tech
    If I am charging the battery @ 6amps, should the alternator get warm?
Top