Ford Mustang Forum banner

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-18 of 48 Results
  1. 5.0L Tech
    Morning, I have a 1992 Mustang GT 5.0 and decided to changed out my valve cover gaskets. During this process I installed new hoses on the intake, due to cracks. Now that I've put everything back together, the car will crank, but will not stay running. It'll fire up fine, but will not idle. I've...
  2. 5.0L Tech
    I just need to replace the rear hose but I can't reach the lower end of the hose to loosen the clamp. What are the parts I would need to remove in order to replace the rear hose? It is definitely in need of replacement. Thank you for your help
    egr
  3. 2005-2010 V6 Mustang Tech
    So, I have an 06 coupe 4.0 with a K&N CAI which has been on for about 40,000. Just last week my engine light came on and its reading the MAF and MAP sensor. I replaced the MAF sensor and reset the light but after 10 miles it came back on. I went to ford asking about the MAP sensor location (...
  4. 4.6L Tech
    Hey all, I've constantly used this forum for advise but never actually posted questions, so go easy on me, this is my first time actually reaching out for some assistance. My car has been idling rough and stalling out, it doesn't matter if I'm sitting at a red light, or if I push the clutch in...
  5. 4.6L Tech
    Ok, so the wifes 2000 4.6 wouldn't start this morning, I went out and took a look at it and behaved as if it were out of gas or the ignition was dead. After LOTS of pumping the accelerator there was NO fuel smell as one would expect if it were getting fuel but not starting. After checking all...
  6. 5.0L Tech
    Hello everyone. I have a 1986 ford mustang gt. V8 5.0. It has several mods. Cold air intake, 70mm throttle body and spacer. Msd ignition/coil. It all started with a very bad idle, now in neutral it idles at about 100 to 300 rpms and blows black smoke out of the exhaust. Also sounds really...
  7. 4.6L Tech
    I have now resolved my idle issue from my last thread. After replacing the IAC and getting the EGR system deactivated I no longer have a problem with a stumbling and rough idle. I do; however, still have the ticking problem that was also described in my previous thread. I had suspected a...
  8. 5.0L Tech
    i went to change my throttle and egr spacer to a 70 mm bbk. and found inside intake some kind of liquid. i put it back together because i spoke to a friend and they said its fine just run it but now im worried. im going to take it off again today and see. anybody have a clue what it could be and...
  9. 4.6L Tech
    I'm currently dealing with an issue with a mustang I just bought that has been sitting for a year. After replacing the fuel pump and a new battery, I was able to get her running. Problem is I have a serious lack of power and around 3k RPM the exhaust hose that hooks up to the EGR position sensor...
  10. 4.6L Tech
    Hi, I have a 1999 Mustang GT (4.6L v8, Automatic), Im having problems on several things: 1- Problems when doing a cold start, I must try several times or accelerate it to achieve it, and some times it backfires on the start. 2 - GAS mileage in the toilet, literally. 3 - When I accelerate it...
  11. V6 Tech
    I just bought this mustang, I replaced the plugs and wires, replaced the right manifold and valve gasket covers.. it idles rough, the car shakes and It's awful while driving down the road. Once I hit 50mph it sounds like a freight train. I have been reading about the when valve and dpfe.(or...
  12. New Member Introductions
    Hello everyone, so i am a student in auto mechanics and recently did an engine rebuild and swap in my '00 V6 that had 244,000km. Problem is now that since i did the swap, i have this issue where when flooring the car it jerks on all cylinders... like its missing air or fuel. I did alot of tests...
  13. 4.6L Tech
    hi guys, im having some trouble with my 96 gt 5 speed. i just replaced my catted h-pipe with an o/r h-pipe because my car was studdering and losing power randomly. i had a check engine light saying insufficient flow or cat below threshold (i forgot), anyway i figured my cats were clogged. after...
  14. 4.6L Tech
    Hey Guys, So the stang is away for the winter, and I bought a bunch of new parts to throw on during the time. One of them was the Edelbrock Victor Jr intake manifold, with a Trickflow 75mm tbody and plenum. It all bolted up fine, but it seems that my egr valve is now about 3 inches behind the...
  15. 2.3L Tech
    So, we have a 1993 LX that has just started giving us idling problems. The idle is super-low, almost to the point of killing the engine. When in drive and accelerating it is fine, but in reverse and park (or when stopped), it barely keeps going. I did a self-diagnostic test and got codes 334...
  16. V6 Tech
    I was messing around with my car today and noticed hot air hitting my hand...when i looked to see where it was coming from i noticed this open hole which was putting out hot air and i noticed it smelled like exhaust...i took a pic of it it's on the passenger side just wondering if this needs to...
  17. 5.0L Tech
    1993 mustang, on a fairly hot day on a drive, my electric fans failed temp gauge went up almost to 220 or so, pulled over and found fuses for electric fan blown replaced them fans came on... waited till temp lowered, restarted... ran fine fans on... cont. driving temp gauge started to rise...
  18. Classic Tech
    I replaced my intake manifold on my 5.0 L, started the motor and hear what sounds like a bad exhaust leak. The only thing I could think happened was the gaskets between the intake manifold and head slipped and the sound I am hearing is the EGR crossover not sealing between the head and manifold...
1-18 of 48 Results
Top