Ford Mustang Forum banner

electrical problems

  1. V6 Tech
    I have a 2004 V6 Mustang with several electrical issues. At first the turn signals and brake lights went out. I took it to the dealership several times to have fuses replaced but they would blow about a week later. Next the CD player stopped working and the volume control began to mess up (If...
  2. 5.0L Tech
    I have a huge electrical issue(s). My car has sat for a few months. I had back surgery in July and couldn't drive. I am now ready to get back in the saddle. I put a new battery in today and tried to fire her up. The motor didn't turn and there was a buzzing sound near my dashboard or under. Then...
  3. V6 Tech
    Good afternoon everybody. I am working on a 1997 Ford Mustang convertible 3.8L and has just over 121,000 miles on it. We purchased the car for a very low price with not many things wrong with it. I have fixed all the things on the vehicle that needed to be done except for the last issue that has...
  4. 2005-2010 Mustang GT Tech
    I have recently installed an Eclipse AVN 6620 nav head unit in my car. While wiring it up i spliced the speed pulse signal wire into a blue wire w/yellow stripe inside the car below the glove box which i thought was the cars speed pulse wire. Now i have relocated the nav's speed pulse connection...
  5. V6 Tech
    So I have a 1999 mustang 3.8 v6 i just swapped the motor to a 2004 mustang 3.8 v6 engine..So its just a v6 to v6 swap..Once i took the old motor out i then put the new one in,after wired up i attempted to start it up..First try=car starts for like 6 seconds then dies,I then try to start it again...
  6. V6 Tech
    I just bought a 95 3.8 l mustang and it had been sitting for awhile so it need to be jumped to start it. Now when i turn the key nothing happens no lights, radio or anything just a clicking noise from the trunk. I just replaced the battery and still nothing. It wont jump start or even try to...
  7. 2005-2010 V6 Mustang Tech
    I have a 2005 v6 Mustang. I have continuous tail light issues. I am always replacing bulbs, left and right, including the blinkers. They do not go out sequentially and I will not lose an entire side at the same time. Has anyone else had this issue? It is very annoying.
Top