Ford Mustang Forum banner

guage

  1. 2005-2010 V6 Mustang Tech
    I have a 2005 mustang v6 5 speed, and the guages ddon't really work. The rpm one works, but the gas sits on E and thd temp goes way past the hottest point and the speedo doesn't even move. Anyone had this problem or know how to fix it?
  2. V6 Tech
    Title pretty much sums it up, How do you disable the PATS system on a 2001 Mustang v6? I aquired a Gt cluster guage but found out if i hook it up the car will not start because of PATS so i need to bypass this obstacle.
  3. 2005-2010 Mustang GT Tech
    Hey question... Gas guage worked fine when i filled the car up. Drove and made a few erronds then I noticed that the gas guage started reading upside down from the bottom. It is getting power because it moves. No "Low fuel light " indicated.. Do you guys have any ideas ? Thanks.
  4. 2005-2010 V6 Mustang Tech
    The fuel gauge on my 2005 V6 is constantly reading full, it doesn't matter if I just filled it up or if it hasn't been filled in one hundred miles. Now I love the fact that she's always full but I unfortunately am lacking the 'Miles Until Empty' part of the MyColor Cluster. This whole problem...
  5. 2005-2010 Mustang GT Tech
    Hey whats up everybody, i had a few questions on installing my vaccum and oil pressure guage. i was told to get a T adapter to install the vaccum line somewhere around the throttle body but i don't know which hose. Also i was told to get a T adapter to install the oil pressure sender unit...
  6. V6 Tech
    The temp gauge on my dash only works part of the time. When it's not working it's pegged way over on the HOT side. The first time it did that I freaked out that it was over heating, but I soon found out it wasn't getting hot, the gauge just pegged cause it broke I guess. Now it only works if the...
  7. Classic Tech
    I have a 289 with AOD transmission. The speedometer cable will not slide all the way into the speedo. After looking at the defective speedo and comparing it to the new one I found that where the cable slides in, on the new one there appears to be a c-clip installed. The defective one doesn't...
Top