Ford Mustang Forum banner

ignition issue??

  1. Classic Tech
    I have a 1965 6Cyl 200 with everything new.New dist. new plugs, wires,cap, rotor, coil, but i keep having to replace the condenser in the coil. Car will run great all day or for several days, or weeks then one day i get in and it starts but misses terrible and pops through the carb. I changed...
  2. Classic Tech
    I have a 1967 Mustang with an A code 289 V8. I recently added an MSD 6AL box to it. I kept the original distributor with points and condenser. It was running great except it had detonation problems with hard acceleration. My brother advised me to pull the distributor out and rotate it 180...
  3. 4.6L Tech
    Okay, so here's the deal. Recently I had an ignition problem in my '96 mustang. The car could be started but it would not switch off. I could put the key in the off position and take it out but the car would still run and all the gauges and lights were still on. After about a week of messing...
  4. V6 Talk
    So I bought a 1998 mustang 3.8L earlier this week. Within the first 24 hours the passanger side head gasket blew. Over the last 2 days, my Pops and I took appart the entire top end of the motor. We replaced the head, intake, and exhaust gaskets and finished reassembly last night. I go to turn...
  5. Classic Tech
    So, I've had this car for about a day, and it was running like a champ. But with my luck When I started the car after I had gotten off work, It turned over and ran for about 2 seconds, then shut off. I dont have much mechanical experience, but I've deducted its either the solenoid or the...
  6. Introductions
    hi to everyone, i bought a 1999 mustang gt but i have been experiencing problems at the ignition, usually i have to try 2 or 3 times before it turns on, does anyone knows what can i do to get out of this problem?
  7. 4.6L Tech
    Hey everyone, About a week and a half ago my service engine light came on. I took it in and got it looked at and the spark plugs replaced... The codes said that it a miss-fire issue so it came then today about 4 days after I got it wiped off the computer the light stated flashing for about 30...
  8. 5.0L Tech
    :waveyHey guys. Just bout half a year ago i lost my keys and never took the time to find them due to working full time again. Then i wanted to look for them 2 months ago and i can't. So.. instead of having any luck of finding them i decided to buy a new ignition with new set of keys. Now.. the...
  9. 5.0L Tech
    93 5.0 popping noise at high rpm out of exhaust on acceleration
Top