Ford Mustang Forum banner

injector trouble

  1. 2.3L Tech
    I Have A 1988 Ford Mustang 2.3 I Have Been Trying To Get This Mustang Going For Now Almost 2 Months And No Luck At All. This Is What Happen 2 Months Ago I Went To Start My Mustang And It Work Fine Then Once I Turn It Off It Would Not Turn Back On. It Turns Fine And Has Full Tank Of Gas . I Did...
  2. 4.6L Tech
    Ok so I have a 97 Mustang GT 4.6L SOHC 5speed. It will start but die 5 seconds later. I thought is was the grounds for the injectors but now I'm not sure. I have replaced the PCM, IAC valve, camshaft position sensor, crankshaft position sensor, EGR valve, intake manifold gaskets, spark plugs...
  3. 4.6L Tech
    I have a 97 mustang gt 5 speed it will start but only run for 5 to 10 seconds. I have checked the fuel pressure and it is fine. i have cleaned the injectors and changed the plugs and plug wires. I disconnected a injector and put a test light in the plug and found the injectors prime the engine...
  4. 4.6L Tech
    Hey Guys, My “Check Engine” light has been on for some time now with no actual problem. When I got the computer read it was a miscellaneous misfire. Now, 6 months later, it is getting worse. I can actually feel a power lag and the light flashes for at most 20 secs. And then I can feel the...
  5. 5.0L Tech
    I recently installed a set of long tube headers and off road X pipe, and now I think the engine is running lean with pinging. I backed off the timing to ~10, but didn't help. I used starter fluid and sprayed around looking for a vacuum leak, nada Do I NEED a custom tune ??? And will it help...
Top