Ford Mustang Forum banner

mechanical

  1. 2011 - 2014 V6 Mustang Tech
    So I've had my 2011 V6 Mustang since September 2015 (3 1/2 months) and today, while I was driving, my SIRIUS radio popped and turned off then came back on. No big deal - thought it was a fluke. A minute later the car starts beeping saying "service advancetrac". I was about 5 minutes from...
  2. V6 Tech
    2002 v6 3.8 convertible choking up and then dies when idle or in park mostly after running for a while, and cannot find an answer. changed filters, throttle sensor and position , new battery new egr val. need help!!
  3. V6 Tech
    Hey Everyone, I've got a 2000 v6 Automatic that is shifting a little harder than I'd like. When I'm in drive and running through all the gears it seems to do just fine, but when I'm in park and I shift it into drive or reverse it shifts kinda' hard. Does anyone know what could be causing this...
  4. 5.0L Tech
    after my supercharger was installed it was running a little hot with stock fan shroud and radiator, then i bought a 3 core rad but my fan shroud wont fit so i dont use it. and it stays pretty cool with the stock clutch fan and a 3 core but i think theres a little more to get out of it. so do...
  5. Classic Tech
    Hey guys, first post in what I'm sure will be an ongoing relationship. I recently picked up a 1 owner 66 289 Mustang in premo shape. Shes a bit ugly at the moment but that will change as time goes by. The 289 has a rebuild with about 15k on it. Its been sitting for a couple of years only...
  6. V6 Tech
    I'm wondering if it's possible to swap a mechanical speedo, like from my 1997 Mustang, for an electronic speedo, like from a 1999 to 2004 Stang. I know that my transmission is wired for mechanical, please don't remind me. This is an attempt to dump this tranny and update. Also, is there any...
  7. 4.6L Tech
    Ok tomarrow Im having a compression check done on my car due to the fact that I keep getting a mis fire on cylinder #5. I am trying to rule out a bad piston ring and hoping its just a bad valve seal or head gasket as to why I am getting oil on the threads of my spark plug. I have done every...
Top