Ford Mustang Forum banner

no power

  1. No electrical power 1966 289

    Classic Tech
    Have a 289 GT that has sat for a few years. It ran when we put it in storage. Recently began the process of getting it back on the road. Installed a new battery, turned it over to check spark. No spark. Since it had sat so long, we went ahead and replaced coil (which I thought was the...
  2. 1990 mustang passenger window working

    5.0L Tech
    Hello I'm new to this forum and to owning a fox body, When we got the car the passenger window did not work and the previous owner couldn't figure out why. We took the door panels off and realized that there's no power going to the motor but the motor works. I've looked at the wiring diagram...
  3. 1991 Mustang No Crank no start, no power after the first starting attempt.

    5.0L Tech
    Howdy. rwavey.gif im oretty mew here and ive come ask for anyones help that can help me figure out what the issue is with my 91' 5.0. The problem started about 3 days ago. i Start my car the first thing in the morning and it too a little longer than usual to turn over, so i figured something...
  4. Foxbody Starts but nothing works

    5.0L Tech
    Hello, I own a 1987 mustang 5.0. It has a mach 1 style hood on it with no covers. Today it rained and I drove my car to work. It worked perfectly fine on the way there. This afternoon, 8 hours later, I quickly hopped in and turned the car on. I noticed the light for my radio wasn't working...
  5. Please Help! 97 Mustang with Major Hesitation and Idle Problems

    V6 Tech
    I just recently got a 97 V6 3.8L Mustang with around 75k miles. It had been sitting with absolutely no use for the past 3 years. I had the fuel pump and spark plug wires replaced. The car does not overheat. It drives almost normal while the engine is still cold. The problem is once the...
  6. Obd II port is not powering my tuner..help please!

    2011 - 2014 Mustang GT Tech
    Hi everyone, 2 days ago, I plugged in my sct Tuner and suddenly, the port was not powering it as no lights were blinking on the device. I connected the device to the laptop using a USB cable. It came on and I successfully updated it to the latest firmware release. I tested all the fuses inside...
  7. No power to fuel pump?

    4.6L Tech
    own a 2002 v6 Mustang and yesterday I was replacing the RED cable that goes from the fuse box to the positive battery terminal. I replaced it and turned it on but today I tried to turn it on and the fuel pump was not responding. The car cranks but it doesn't turn on. What could've have possible...
  8. Won't turn over, lots of clicking in passenger fender well.

    V6 Tech
    97 3.8... Thought it was the battery, bought a new one and didn't fix the problem. Pulled into a parking lot, parked in front of a store came back out 3 minutes later (Las Vegas). I put my key in the car to turn it over and there is no response, no power at all except for a slow blinking CE...
  9. 2006 Mustang V6 electrical failure

    2005-2010 V6 Mustang Tech
    So I decided to make an account on this website because, well, I can't figure out what's wrong with the electrical system in my car. I've had this car for a little over a week, and I've not had any problems out of it until this morning. When I tried to unlock it with my remote, it wouldn't do...
  10. 2006 Mustang V6 electrical failure

    Introductions
    So I decided to make an account on this website because, well, I can't figure out what's wrong with the electrical system in my car. I've had this car for a little over a week, and I've not had any problems out of it until this morning. When I tried to unlock it with my remote, it wouldn't do...
  11. 2006 Mustang V6 electrical failure

    Introductions
    So I decided to make an account on this website because, well, I can't figure out what's wrong with the electrical system in my car. I've had this car for a little over a week, and I've not had any problems out of it until this morning. When I tried to unlock it with my remote, it wouldn't do...
  12. Power Issues after Tons of Work!! Help Please

    Introductions
    Hello All, Here is some history; I have a 1993 Mustang LX Convertible 5.0 Work done: ---Brand New Rebuild--- Stock 5.0L Block Bored .030 over Ported & Polished AFR 165/202 Heads 1.6 Roller Rockers Forged Pistons Forged Rods (X Cam I believe - can find out for sure if needed) Ported upper and...
  13. 94 5.0 struggles after 3000rpm and wont go over 110 PLEASE HELP

    5.0L Tech
    Hey so i have a 1994 mustang gt 5.0 ho. It has 86,000 original miles. The person who had it before me bought it with 79,000 miles in 2000 and i bought it January 2012 with 83,000 so it was sitting for a while. Ever since i bought it something just never seemed right about it but since i was...
  14. 1965 mustang No Power to lights ignition or dash

    Classic Tech
    I have a 1965 mustang with a 351 windsor crammed in it, I didn't do the swap, and the electrical has already been rigged by who ever did it, but everything worked without issues. I went to install a new set of gauges, Temp Oil pressure and Volt meter. The car already came with a Temp Oil...
  15. 1999 mustang 3.8 No Power on acceleration, anyone know what this part is?

    V6 Tech
    1999 mustang 3.8 No power, hesitating, sputtering and backfiring when accelerating. It has no power, it's hesitating, sputtering, popping and backfiring when accelerating. Runs a little rough at idle, but revs up with only a second's hessitation, until it's under load, then it just bogs right...
  16. 5.0 New cam no brakes at idle

    5.0L Tech
    I just got my car running look at the sig for mods. The car is an aod with stock torque converter so I dont want to raise the idle and risk it jumping off the brakes but that raises another problem... Theres no brakes at idle!! They feel like manual brakes, I have to stomp on them to stop the...
  17. 1998 Mustang Coupe with no Electrical Working

    4.6L Tech
    I ran to the store and when I came back out to go home she wouldn't start. In the "accessory" position the lights/radio came on, but as soon as I tried to start the car I lost all power. Somebody tried to jump start me, and it still didn't even give me any lights. I have absolutely no power; no...
  18. 90 GT Conv - Rear Running Lights INOP

    5.0L Tech
    Hi guys, my rear running lights are not working. Rear Blinkers, Brakes, Hazards work just fine. The front is 100%. It is just the rear running lights. I checked it with the volt meter and the running lights are getting no power, checked fuses...all good. Does anyone have any ideas or...
  19. Engine Stall with Automatic Transmission

    Classic Tech
    I am having trouble all of the sudden with my 351W/FMX combo. I just rebuilt the engine and got a rebuilt torque converter. The engine runs fine and idles fine. After I rebuilt the engine, I had to drive it about ten miles to the muffler shop to hook up my exhaust. It ran fine down there with no...
  20. Run/Access Pin in 2009 Mustang Pony Package Not Supplying 12+ VDC to Turn on New Deck

    Audio, Video, Navigation & Alarms
    Hi, I have a 2009 Mustang Pony and I'm looking to replace the factory shaker 500 with my own Kenwood deck. I've looked online at the wiring diagram for the stock harness and matched up all the pins correctly with the aftermarket plug i bought. When I plug the deck into the stock harness in the...
Top