Ford Mustang Forum banner

oil pump

  1. 2005-2010 Mustang GT Tech
    Hi, Im new to this site! So my mustang GT 2006 [V8 4.6] just started recently to have this issue, I start the car and after few minutes running it; it sends the message "Low Oil Pressure" and starts to do a knocking sound. If I turn it off and let it cool down few minutes before starting it...
  2. 5.0L Tech
    I have a 1989 gt. I was out of town for a while so when I came back I did a tune up on the car. Chnaged wires spark plugs. Fuel filter . U know the usual. And when I started it it didnt sound good. It started up fine but its making a hissing sound like air leaking and also sounds like a metal...
  3. 5.0L Tech
    Im helping a friend of mine put together a street/strip engine and Ive got a question about the oil pump.The engine is a 306,forged flat top pistons,crank has been turned and polished .10 under with 10 over bearings,stock rods,then the typical 350 hp bolt on trick flow package.This car will be...
  4. 2011-2014 Mustang Talk
    I got a 2013 5.0,I have the roush tvs kit on the way from vmptuning,I'm going to run the 82mm which should put it around 10psi,should I be concerned about the oil pump gear failing at this psi,I don't plan on taking the car above 7300
  5. 4.6L Tech
    This brief article explains the differences between cobra and non cobra pumps as well as what to look for, even with a new oil pump. 4.6 Liter Ford Engine Lubrication System
  6. 5.0L Tech
    Hi, I have an '89 GT and I've been getting really weird oil pressure readings. From start up the pressure seems fine and sits a little below the halfway mark on the factory gauge, but when I accelerate or beat on it the oil pressure seems to drop off very drastically. The motor is almost all...
  7. Classic Tech
    I am having trouble finding the correct oil pump drive shaft. I have tried the normal 289/302 shaft but it is 1.5" too short. This is a C8AM casting and I am not sure if it is a 289 or 302, but the heads say 289. The OEM is 7" and I need an 8.5" shaft. Any ideas on the shaft? Thanks
  8. V6 Tech
    my 2001 mustang keeps squeeling and killing the engine occasionally i've replaced the idler pully the tensioner pully and the water pump to no avail. i then ran the engine without the serpentine belt on and the problem is still present, so i dont believe it had anything to do with belt driven...
  9. 4.6L Talk
    Hello my fellow mustang owners, I am new to this forum and are the proud owner of a 1996 mustang gt. I should have pictures up soon but to get to the real problem. I recently installed a oil pump, and when i go to crank the car it will just crank, have the low oil light on. Now i knew that i...
  10. Classic Tech
    We're rebuilding a 66 with a 200ci inline six. Putting together the bottom end, and we see that our gasket kit and oil pump don't have a gasket between the block and the pump. I thought these engines had a gasket between the pump and the block. Can anyone confirm this?
  11. Introductions
    hey i got an 89 lx mustang and i went to take my distrbtor out and i saw that my driveshaft broke and i wanted to kno if there was a way to replace it from the top without having to deal with pullin the motor or anything
  12. 4.6L Tech
    ive just orderd the mmr race/street oil pump for my mustang thats ganna put down around 500hp has any one had any issues or has any one been satisfied by its performance any and all imput is apreciated thanks PS the motor is a brand new 03 cobra bottum end with notched pistons with upgraded...
  13. 5.0L Talk
    Should I patent this product or, do you think I will have enough demand for it? The other day I had the issue of not installing the oil pump shaft when putting the oil pump on. So I made up a tool which would be able to hold the oil pump shaft clip and at the same time slide the clip down...
  14. 5.0L Tech
    Ive got a stock 302 with an e303 cam. Now I was talking to a friend and he was saying that the stock oil pump shafts can strip due to changing the timing. I've never heard of this before so just wanted to see what you guys think. BTW what should my timing be at with this? 11 12 maybe even 13...
  15. 5.0L Tech
    Hey guys: The other day I had the issue of not installing the oil pump shaft when putting the oil pump on. After about a week of thinking, I made up a long hard handle and then what I did was I welded a large nut onto the end of it, just so it would support the oil pump shaft clip, what the...
  16. 5.0L Talk
    I am 17 and i just spent 3 night working on my mustang just to be back in the same place i was before. Here is the problem i was/ am having. My oil pressure gauge was going up and down and at idle, wasnt showing anything. The mechanic said that i either had a bad oil pump or the sludge in my...
  17. 5.0L Tech
    1987 stang 5.0 5spd, my oil pressure wouldnt come up then i herd my lifters talking to me, pulled the distibuter and whoaa no oil pump shaft there, pulled the whole front end off and found the other end of the shaft in the pan, now i need to figure out how to fully remove the oil pan to remove...
  18. Classic Tech
    Well.. Here is my first post at the site. Looks like a wonderful site with a good group all with similar interests. Here is my problem. I have a 1969 Mustang Coupe with a 351W engine. Last year I rebuilt the engine and on its maiden trip down the road the new oil pump locked up. I towed the car...
Top