Ford Mustang Forum banner

popping

  1. 2011 - 2014 Mustang GT Tech
    Hey everyone, I am Daniel, I am new to the forum. 2 and half years ago I bought a Mustang GT 2013 automatic with 42000km / 26000mi on the odometer, I am the second owner. Since two days I have a problem with my mustang, it has roughly 64000km / 40000mi on the odometer now. I recently drove on...
  2. 5.0L Tech
    Hello 5.0 Tech. So i've been experiencing a popping noise for quite a while now but havnt had the time to take care of it. It happens everytime i start my car up. After it cranks over and fires up it sounds very similar to backfire and will go on for around 30 seconds. I would compare it to...
  3. Classic Tech
    Hey everyone, I just made a similar post but I thought I'd start one slightly more relevant to the problem. My Autolite 1100 is making a really loud crackling noise at idle. You can hear it even with the air cleaner on. It sounds like someone is sucking up fluid with a straw, but a lot louder...
  4. Classic Tech
    Hello All: let me first thank everyone in this forum and learned a lot from it. I am having trouble with my freshly, professionally rebuilt engine. 289, 2 Bl carb, autolite 2100 ( freshly rebuilt ), timing now at 12 degrees BTC ( i tried anywhere between 6 to 12 degrees with vacuum off and...
  5. 5.0L Tech
    Hello, first of all mine is a 91 f150 with a 5.0 and hopefully I don't get booed out of here for that but I really need help. I recently rebuilt my engine with new everything a bigger .485 intake and exhaust cam, ported upper and lower intakes and heads, and shorty headers. I kept the obd-1 as I...
  6. V6 Tech
    hello hope everyone is well i have a 2000 Mustang vert, 3.8l, 5spd, 160,000kms which i am experiencing some trouble with. Car Symptoms: Popping noise through air intake (random), eng seems to die when this happens When eng dies, dash warning lights all illuminate and odometer goes straight...
  7. 2005-2010 V6 Mustang Tech
    Hey guys, okay so on my 08 V6 automatic coup, Ive had this sorta popping sound when I apply the brakes. It happens really random and I know its coming from the front I thought it was coming from the driver side front so I changed the brakes on that side since I changed them like 3 weeks ago. And...
  8. Introductions
    Hi, I have a 1989 mustang gt, it had a dead cylinder. I checked for spark and it had it. had the injector flow tested and it was also perfect. The car is popping back up through the intake and making the butterfly pop in the throttle body. Does anyone think it could be a bent valve or stuck...
  9. 4.6L Tech
    I have a 1996 Mustang GT and i noticed there is a popping sound when i apply heavier braking, usually right before a complete stop, and the sound comes from the front driver side of the vehicle underneath, what could this be?
  10. 2011 - 2014 Mustang GT Tech
    I installed a set of BMR lowering springs on my 2011 GT a couple months back, and I have noticed a popping noise in the front suspension when I hit bumps that rapidly compress then decompress the suspension (i.e. hitting a speed bump too fast). However this only happens when the suspension...
  11. 2005-2010 V6 Mustang Tech
    There's nothing I can do right now with no money, but since I'm not sure exactly what problems the car has, it can't do any harm to get some opinions to figure it out. Transmission I believe the synchromesh is broken. I've read, though, that it's individual to every gear, yet shifting into any...
  12. 4.6L Tech
    i have a 2002 gt pretty much stock just exhaust and intake.......needin some help on this one. i have a popping noise coming from the motor while at idle and a shutter while maintaining speed at low rpm's. sounds to me like its running lean. any help?
  13. 4.6L Tech
    So this is what happened. I was driving yesterday just in normal traffic not reving my enginge or oranything jsut staying between 1-3rd gear. I came up to a stop sign, made a complete stop, and as i pulled away i noticed an odd sound coming from my engine, it started making a loud "popping"...
  14. Classic Tech
    Hey All! So. I fixed my car! It was a fuse, rather, a couple fuses, that were draining the battery. After horribly contorting my body to get to the fuse box and take them out, I charged the battery, started it up, and TA DAH, it worked. Finally. Now that the engine is actually running, I hear...
Top