Ford Mustang Forum banner

pressure plate

  1. 5.0L Tech
    Sorry im new here. I have a problem on my buddy's 1990 GT hatchback. We cant seem to get the car to release the clutch. The clutch cable is fine, clutch quadrant is stock but works, the clutch fork fully functions and i can see the throwout bearing pushing in on the pressure plate. My...
  2. 2011 - 2014 Mustang GT Tech
    I am ordering a 2014 GT soon and considering the base model GT with the Track Pack which I understand is well worth the $$ for the included upgrades. I read somewhere that the Track Pack also includes a Carbon Fiber Pressure Plate to reduce heat. Did I dream that or is it true and is a good...
  3. 2005-2010 Mustang GT Tech
    The clutch has needed adjusted since my hubby got car. He had put it off b/c he was just going to put a short shifter in. It wouldn't start sometimes, like I didn't have clutch all the way in, or grind into reverse. Then a couple of times it felt like the clutch peddle wouldn't come up for a...
  4. 2011-2014 Mustang Talk
    Hello- I am submitting info to an attorney in regards to issues I currently have with my car within 10 months... My car has been in the shop 4 times for the same issue and it appears everytime I get it back, it's worse... If you are also experiencing the same issues with your vehicle send a...
  5. 5.0L Tech
    i just bought a used (400miles) clutch kit with flywheel today. its manufactured by valeo but dont know if its the same as the ford racing clutch. its a gray/silverish pressure plate, and a clutch disc with 5 light blue springs on the hub, non-puck style. numbers on the disc are 167705 180203...
  6. 4.6L Tech
    I am in the middle of putting in a new clutch in the Stang. I ordered and drove all over town picking up the (3) dowels for the pressure plate to flywheel alignment. They gave me STEPPED dowels (Ford#6397) and the larger end that sticks out of the flywheel is too large to fit in the P. plate...
  7. 2005-2010 Mustang Talk
    The pressure plate just went out on my 05 V6....I have had it for 45 days and its only has just over 44,000 miles. Its requiring an ALL NEW clutch... Is this a common problem, and can i expect it to happen again? I know its an EXPENSIVE problem. :headscratch:
Top