Ford Mustang Forum banner

short circuit

  1. 5.0L Tech
    I just bought a 1990 Ford Mustang LX Hatchback and didn't nothing pennies stuck in the 12V plug when I plug in my GPS. I stalled the car out a few times being this my first manual transmission car but now it won't start. Me and the guy I bought the car from did some trouble shooting and the...
  2. 5.0L Tech
    So I am having some trouble with my turn signal wiring on my 5.0 Mustang. The car has been sitting for over a year and the ignition was recently replaced by my father who was too impatient to just get my key so he put a new ignition to move the car to another spot in his junk yard. I was...
  3. 4.6L Tech
    Replaced engines to a '96 from a '97. battery light came on. Checked battery and alt. even swapped alternators and same thing. then i swaped wire harness's with one I know is good, same outcome. checked and rechecked every connecton in engine compartment. problem is, I bought the '96 with a...
  4. Classic Tech
    Hi, I have searched the forum and did not find my exact issue. Some months ago I changed out the 44 year old wiring as I was afraid it would eventually burn my car don. It took a week and all was working properly. Initial symptoms: One morning some weeks after installation. I drove with my...
  5. 4.6L Tech
    I have a 2001 Mustang with the Mach 460 system in it. About 6 months ago I began having all kinds of electrical problems. The car had to be jumped every time I wanted to start it. After paying a truckload at the dealership, I finally found an Auto Electronics shop to take it to, who informed...
  6. V6 Tech
    Okay so i was washing my engine off when I believe I accidently got water on the right blinker wires that were stripped to allow power to get to the halo headlights. well I go to turn on my car and it starts, and then starts to putter and go down to way below one RPM and then die. I also noticed...
Top