Ford Mustang Forum banner

slip

  1. 4.6L Tech
    My tranny started slipping a couple weeks ago and then it just stopped shifting. I cleaned the pan and replaced tranny filter. I put in all new fluid and it started fine but slips in drive. Reverse and everything else is fine. But in drive it takes forever to accelerate. Any help??? 1996 v6 3.8L
  2. 5.0L Tech
    Hey everyone, I have a 89 foxbody I recentally did a 302 swap and some other mods done to it. After I finished the swap I took it on the street and the clutch was slipping so I thought it was because of to much power for the stock clutch. I bought a stage 2 clutch put it in and it grabbed but...
  3. V6 Tech
    I have an 03 Mustang V6 base model and am having a slip issue that I'm not sure where it's coming from. Only during most turns, not all, I will slow down normally, make the turn, and about 75% into the turn, I will give it gas and the engine will just rev up and finally catch and lurch forward...
  4. 2.3L Tech
    My clutch is slipping nice and awesome. I finally fixed my clutch pedal click btw, thanks to everyone who responded there. Should I get a whole new clutch, or just get everything resurfaced? Thanks all, PRB aka "Apollo".
  5. 2.3L Tech
    Alright so my car keeps killing me with problems. I love her but geez. Anyways newest problem. My clutch was slipping a little, so I did the "self-adjustment lift the pedal up with your toe" technique. Now here's the problem. It adjusted itself to the floor at first, but with a nasty click about...
Top