Ford Mustang Forum banner

starting issue

  1. help needed!

    4.6L Tech
    I have a 1995 mustang with a 2000 gt engine in it. Today the ground wire (the wire that grounds the negative battery cable) was coming loose and causing a big mess. It was causing the car to jump around, in the process of stalling sort of, and eventually, it cut off. Now I was able to push the...
  2. 1966 --289 coupe starting issue

    Classic Tech
    Alright .... another issue ... needing assistance. car will start and run initially, once turned off the car will not start again. it cranks but sounds like its not getting enough voltage. checked battery and is ok. 12 volts. checked the coil while cranking and its only registering 5 to 6...
  3. Edelbrock Carb Problem

    Classic Tech
    Hey all, Today I installed a Performer RPM and a Edelbrock 600cfm electric choke carb on a 351w. I got the distributor dialed in and adjust the carb well and the engine was running great. I took the car out and the car felt strong and then all of a sudden the engine quits. I pulled over and...
  4. 1990 Mustang shorted out 12V plug. car won't start just turns over

    5.0L Tech
    I just bought a 1990 Ford Mustang LX Hatchback and didn't nothing pennies stuck in the 12V plug when I plug in my GPS. I stalled the car out a few times being this my first manual transmission car but now it won't start. Me and the guy I bought the car from did some trouble shooting and the...
  5. 91 Mustang Wont turn over

    5.0L Tech
    Hi everybody, I have a 1991 Mustang GT drop top and she wont turn over. I've recently replaced the distributor, coil, ignition module, rotor and cap. When i got her going after all this she ran for about 4 blocks and died. I tried restarting and the starter would not disengage. I pulled the...
  6. Electrical Problem?

    5.0L Tech
    So here's my problem: The other day, I drove my 88 5.0 to my friends house. Everything was working perfect until I went to start the car and the battery was drained. Tired jumping it, with no success. In fact, when I would turn the key to start position, you could hear the engine from the other...
  7. 1966 rebuilt 289 startup noise

    Classic Tech
    Hey guys, So the 289 (and c4) in my 66 coupe was just rebuilt and we got it put back in the car a couple weeks ago. Every time we have started it since then, the initial noise during and right after cranking is this grinding noise. Its not a very loud grinding just loud enough to cause me to...
  8. Im having starting issues.

    Classic Tech
    How is it going? I have a 1966 Mustang and its been running fine until today? It won't start up. Its electrical issues. I've replaced the starter solenoid, alternator, and voltage regulator. I had the same issue about a year ago but I just had to get the voltage regulator replaced and I also...
  9. 1966 Mustang Started all Day then suddenly wont

    Classic Talk
    I started my 66 all day 5-6 times, no issues. Started fine, quickly, smooth. Then suddenly last time it started cranking realy slow. Thought it was a dead battery - got a jump. Tried starting in Park and Neutral Did not help at all with minmal improvement in the crank speed / duration. I...
  10. 67 mustang starting issue(reves to 5000)

    Classic Tech
    I got a problem at start up, go to start car and takes a few cranks spitting and sputtering not wanting to start. Then when finally does start reves straight to 5000 rpm. I hit a tree about 9 months ago and had to do a lot of repairs before I could put it back together. Does anyone know what...
Top