Ford Mustang Forum banner

stutter

  1. 4.6L Tech
    I started my vehicle yesterday and noticed it was a little sluggish and soon as I jumped onto the highway it started to stutter as I accelerated and the exhaust sounded muffled so I kept driving for a few minutes and then observed the Service Engine Soon light blinking so I pull over popped the...
  2. 4.6L Tech
    I have a 2000 Mustang GT with 152,000 miles and a manual tranny. About 5 months ago, I was having this problem of a stutter when under medium to heavy acceleration. It did it more when it was revving lower than higher. The CEL finally came on saying I had a misfire (this was the 2nd time I've...
  3. 5.0L Tech
    i have a 93 mustang gt 177k. it seems to have a little rough idle engine seems to shake just a small bit, something many people wouldnt notice but i do, engine idles perfect at 800-1100 but just seems to stutter.
  4. 4.6L Tech
    Ok I've got the notorious backfire/sputtering problem and until I can get to the car this weekend to check some of the easier stuff, I thought I'd get some feedback for the specific situation I'm seeing. Basically since I've bought the car a couple months ago it's done the backfire pretty...
  5. 5.0L Talk
    Hello guys, this is my first post here. I have a 95 5 speed GT without any mod's to it. In the past month or two I have had problems with it starting and running. Sometimes it would, start sometimes it wouldn't. It would occasionally cut out while driving. We ended up replacing the...
  6. Classic Tech
    I have a '67 with a 289 2v and a C4 trans. I have mentioned this problem before but I never figured it out! When the car is fully warmed up if I let off the brake, the car rolls forward with no problems, but if I give it about 5-15% throttle, it will stutter and may stall on take off. If I give...
  7. 5.0L Tech
    I have a 1987 mustang gt, bone stock besides bbk cai, and o/r h pipe, and i just replaced plugs and wires. ive been having a problem with throttle response, while in neutral it revs fine, as soon as i shift into gear it bogs down and i have no acceleration, but it only does it once it warms up...
  8. Classic Tech
    Hello, I am having a problem with my 1967 Mustang. The car has a 289 2bbl engine with an automatic transmission and power steering. No a/c and no power brakes. Everything on the car is stock. It stutters and sometimes stalls when accelerating from an idle. If you give it a lot of...
Top