Ford Mustang Forum banner

vacuum

  1. Cold lean condition/misfire

    2005-2010 Mustang GT Tech
    On cold starts, my car misfires while accelerating. I have a wideband that I know is accurate, so I know it is leaning out. Knowns: Directly related to heat Symptoms dissappear after car heats up Symptoms are less severe/last less time when the car has been sitting outside in the sun all day...
  2. This "popping" has me stumped. Any help? Been an all summer thing.

    Classic Tech
    So I posted on here about a month ago about my 1968 Mustang with a rebuilt 302 in it. I've rebuilt the carb twice. New distributor, new pertronix ignitor (my problem was still there with the points) new cap and rotor. Already did a compression test. Did the spraying around the intake for...
  3. High Idle?

    Classic Tech
    Hey guys, I just recently resolved some carb issues thanks to your help. My new problem is that the car seems to idle high. Everywhere I read, they say the 1965 200ci mustang with auto tranny should idle at 500-550 rpm in gear once it's warm. As I adjusted the idle down, anything before 600...
  4. Vacuum leak

    2.3L Tech
    Hi , my name is Josh , I have a 1989 Mustang LX 2.3l, I have a vacuum leak , rodents got to my lines , the bottom left vacuum line was totally missing after the car sat for a few months . The car runs ok when its cold , but as soon as it warms up , I have difficulties keeping it running at lower...
  5. Vacuum leak

    2.3L Tech
    Hi , my name is Josh , I have a 1989 Mustang LX 2.3l, I have a vacuum leak , rodents got to my lines , the bottom left vacuum line was totally missing after the car sat for a few months . The car runs ok when its cold , but as soon as it warms up , I have difficulties keeping it running at lower...
  6. Vacuum readings are high. HELP!

    4.6L Tech
    Specs: 2004 Mustang GT Vortech V-2 (water to air intercooler) 60# injectors Stealth Fuel Pump BBK T/B I am currently seeing 360 hp and 340 ft/tq on the most recent dyno pull. Just two months ago it was at 400/400 hp/tq. My boost gauge shows anywhere from 5-10 in hg while at idle. When I...
  7. 4.6 mustang vacuum line connection with trick flow track heat intake

    4.6L Tech
    I have a 97 4.6 mustang gt with a 2001 PI head swap. I have the 2001 Trick Flow Track Heat upper and lower intake manifold kit. I'm confused as to where my vacuum lines connect and which lines connect to the 3 brass barbs (1 large and 2 small) that come out the passenger side of the upper...
  8. Surged idling and running rich

    5.0L Tech
    I just bought a '92 lx 5.0 hatch today, and I believe it has a vacuum leak. I've been told to spray carburetor cleaner around possible leak areas to try and find it. I haven't been able to locate the leak, but it might be in between the upper and lower intake manifolds. Right now, the car runs...
  9. 1991 Mustang gt idle surging

    5.0L Tech
    My 91 has just recently started the whole "I'm a typical Ford and I don't want to behave when cold staring". This just started very recently, it surges constantly between 2500 and near stall out (approx) when I start her up first time for the day. Now it'll do this for about twenty minutes or...
  10. Edelbrock Secondaries Lock

    Classic Tech
    Okay so I have an edelbrock 1406 and I have a question about the secondaries. When I manually pull the throttle when the car is off, the secondaries only open slightly because a lock plate hooks around a notch on the secondary shaft and keeps them from opening. The rebuilt kit i bough calls this...
  11. 302with low rpms when I put it in gear. Please help

    Classic Tech
    I have a 68 mustang with a 302 in it. Its got a holley 750 on it. I was driving along and the car started acting funny. When the car is in park it holds 900rpm idle but as soon as I put it in gear the rpms drop down to 300. It dont stall but when I go to give it gas it runs horrible until 1800...
  12. High Idle on 351C

    Classic Tech
    Hello Everyone- I finally got my 351C 4barrel to turn over but I have an issue with it idling too high while it's in park. The idle will drop as soon as I pop it into gear. I’ve tried tampering around with the two rods in front of my 600CFM Edelbrock Carb. I’ve also sprayed the engine with a...
  13. 2002 Mustang GT Hissing noise on startup/idle

    4.6L Talk
    When I start it up, the first 10-15 seconds are simple no hissing whatsoever. Then the hissing begins: This is how it goes... After about 10 seconds after startup there is a "hiss" sound for about 2 seconds then stops Then another "hiss" sound for about 2 seconds then stops Then there is a...
  14. 2002 Vacuum issue

    4.6L Tech
    I have a 02 GT that is giving me some problems. I got home from work and parked it and it was running fine. I didnt drive it all weekend and got in it monday to go to work and it was running ROUGH! I went back home and lifted the hood and the vacuum line going from the intake to the valve covers...
  15. Help trouble shooting an idle issue. 1990 GT

    5.0L Tech
    Hello, I have had this idle issue for some time now. Cant seem to figure out what it is. My car will idle fine then when it gets warmed up it surges and drops and keeps doing this until the car stalls. If I unplug my IAC the car will idle all day long. As soon as i drive it it wants to stall and...
  16. 5.0 New cam no brakes at idle

    5.0L Tech
    I just got my car running look at the sig for mods. The car is an aod with stock torque converter so I dont want to raise the idle and risk it jumping off the brakes but that raises another problem... Theres no brakes at idle!! They feel like manual brakes, I have to stomp on them to stop the...
  17. Edelbrock Performer RPMII vacuum routing help

    5.0L Tech
    I am getting ready to put my new edelbrock performer rpmII on my 5.0 but have no clue how to run the vacuum likes their is only 2 wholes in the bottom and one port on the side does anyone have any pictures of how i can do this it would be appreciated thanks!
  18. 1989 Mustang Cobra Mysterious vacuum leak?

    5.0L Tech
    I recently bought an 89 cobra, Its got a 5.0 bored out to a 306, ported heads, holley systemax upper and lower intake, bigger injectors not sure of the rate, comp 2030 cam, cold air intake, and its plumbed for a shot of nitrous. When i start it up cold it will idle smooth for about 10/15 seconds...
  19. 1966 289 2V Tuning HELP!

    Classic Tech
    I need to know a little bit about tuning the 289 with a 2V carburetor. Obviously I'm doing it wrong because I cannot get my car running correctly and smoothly. Here's what I've done: Adjusted timing to 9 degrees BTDC. It was set VERY close to TDC before. Installed Pertronix Ignitor 2...
  20. SVO idle problem, maybe more

    2.3L Tech
    i have a 1984 mustang 2.3L svo and i just had to replace the auxillary shaft and the distributor because the teeth in both just got chewed up, while i was at it i swaped the turbo from my 1987 ford thunderbird turbo coupe and put it in my SVO because i was told the turbo was bad. but other than...
Top