Ford Mustang Forum banner
wiper motor

Discussions Showcase Albums Media Media Comments Tags Marketplace

1-6 of 6 Results
  1. 2005-2010 Mustang Talk
    I know this is a common problem but I am dealing with the wipers not functioning in my 2005 mustang. I knew about the cowl drain problem and I assumed my wiper motor brain might have been fried so I bought another. This unfortunately didn't fix this issue. I did confirm 12 volts to the connector...
  2. Classic Tech
    Hey guys, I'm having an issue terminating the wires to the back of my windshield wiper motor and switch. I have a 1966 mustang and the previous owner installed a 1967 American autowire wiring harness. Needless to say I've ran into all sorts of issues with terminal connections and color...
  3. 5.0L Tech
    Looking for suggestions befor I start digging into it I had wipers when I went to work went to go home and no wipers every thing on the switch works even the washer spray but no wipers blinkers work they are a little on the slow side and the high beam works I did notice in the fuse box that the...
  4. V6 Tech
    Hey guys, I'm new to this. I have a 2000 V6 Mustang, and my windshield wipers have completely stopped working. I have tested my windshield wiper motor and with my wiper switch being completely off my wipers will start to work. As soon as I take the wire I am using to test my windshield wiper...
  5. V6 Tech
    I just bought my 1997 V6 and I think that the guy before me ripped me off. But lets move on to the issue: As soon as I put the fuse for the windshield wipers in the wipers continuously run. I can slightly vary the speed of the wipers but that's it. My thoughts are that I either need a new...
  6. V6 Tech
    Hi everyone, I have a 1999 GT. It was raining the other day and all of a sudden the wipers stopped in the middle of the windshield. I check the fuse (#26 - 30A) and it was blown. Replaced it and it blew again. Replace it again and listened carefully. The fuse blew instantly when the car...
1-6 of 6 Results
Top