Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
My 01 mustang seems to hold idle. it stays up in the rpms and doesnt drop like it should. sometimes i have to stop the car completely and let it idle down and it causes it to not shift into 5th gear, but it has a 65mm throttle body a throttle body spacer and a bbk cold air intake i dont know if one of the mods is keeping the idle up but something is wrong. Any help will be appriciated ( the car is a manual )
 

·
Registered
Joined
·
4,521 Posts
Check all the hoses, vacuum and all those connected to the intake/tb, etc
Also clean your TB, TPS and IAC.

Most of the time bad idle has to do with a leak or unmetered air getting in.
 

·
Registered
Joined
·
6,859 Posts
+1 on checking for vacuum leaks. #1 cause of idle issues.

But are you are aware that the Mustang as two idles. A slow idle and a fast idle. The fast idle is used while the car is MOVING. The slow idle is engaged only when the car's speed is zero.

So an idle around 1100 RPM's while the car is moving is normal.

Here's some more information on how to trouble shoot IAC/idle issues:

http://www.allfordmustangs.com/foru...ng-idle-idling-rough-post2260649.html#2260649
 

·
Registered
Joined
·
40 Posts
I had a similar idle issue a couple months back. ('01 V6 automatic.) My throttle position sensor (TPS) was bad and causing my idle to be erratically high. Switched it out and I haven't had any issues since, and as a side effect my MPG increased slightly which was a nice surprise.
 
1 - 4 of 4 Posts
Top