Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
30 Posts
Discussion Starter #1
i just got an 02 mustang gt.. well i fixed little things that was wrong with it im down to the last wire... im showing a misfire in cylinder 2 so i bought new spark plugs and then a new coil pack for that cylinder.. it went away for a little bit then came back the same thing so then i moved the fuel injector to number four cylinder and its still saying cylinder misfire two.. question i bought the coil from autozone but people say their no good but my friend bought his from the same place and it was fine?? okay another thing is the other two codes that come out say i have two bad O2 sensors and somebody said that could be causing the misefire... the cars pretty much stock but the exhaust was done recently by previous owner.. 2 1/2inch pipeing with a x-pipe and 40series flowmasters all new.. and also the guy said he gutted out the cats so idk... anything will help p.s my car runs good especially hauling ass its just runs a little funny at a idle of at low speed so... :worship
 

·
Registered
Joined
·
266 Posts
check the coil connector, i broke the clips of 2 of those things causing misfires on my stang which were annoying.
 

·
Registered
Joined
·
8,704 Posts
check the coil connector, i broke the clips of 2 of those things causing misfires on my stang which were annoying.
This. I had the same thing, a really slight misfire but was happening under load and below 1500rpm. I used a black zip tie to secure the connector (just wrap it through where the clip is and tie it around the fuel rail). Also be sure to squeeze some dielectric grease into the connector.
 
1 - 4 of 4 Posts
Top