Ford Mustang Forum banner
1 - 4 of 4 Posts

· Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I recently installed BBK headed in my new edge. 3 days later while driving the oil gauge went for mid way to Low and knocking sound coming from engine. Stoped at red light and engine shut off . And would not start for 3-5 min. Checked oil and it was low , I change the oils 500mi ago. New to mustangs and would love some help / guidance
 

· Administrator
Joined
·
7,430 Posts
Welcome and thank you for joining ALLFORDMUSTANGS!
Please read the Site Rules if you haven’t already.
We encourage you to complete your Account Settings.
If you need help posting, please read this FAQ.

We’re happy you have chosen to be a part of our community.

Someone will be along shortly with advice.
 
  • Like
Reactions: 5.0 Coyote

· Tech Advisor
2014 GT, 1967 Fairlane GTA
Joined
·
5,402 Posts
I recently installed BBK headed in my new edge. 3 days later while driving the oil gauge went for mid way to Low and knocking sound coming from engine. Stoped at red light and engine shut off . And would not start for 3-5 min. Checked oil and it was low , I change the oils 500mi ago. New to mustangs and would love some help / guidance
How long did you drive it with the oil pressure low or nonexistent?
How long was it knocking?
Was the CEL(check engine light) lit?
When you say "not start" do you mean wouldn't even crank over?
If the engine wouldn't even crank over then the lack of oil damaged your bearings and the engine needs to be rebuilt if it's even possible. When you have an oil or knocking issue you need to shut it down and pull over immediately to avoid engine damage.
 

· Registered
Joined
·
62 Posts
If you changed the oil 500 miles ago and it's already low you have a leak somewhere and need to find it either that or you're burning lots of oil. Any smoke from tailpipes? How did you install the headers? Engine in or out?
 
1 - 4 of 4 Posts
Top