Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
i have a 66 200ci mustang coupre. my battery kept dying, so i had it tested and they said it was a bad battery,, so i bought a new one, put it on. didnt drive my car at all, and the next day it was dead. so something is draining the battery, i dont think its the alternator because i didnt drive it at all and it died. i have a high quality alarm, but ive had it for a couple years with no problem.. just recently the where u put the key in the ignition got jammed,, and its difficult to work the key in and out.. so maybe its staying with ignition on.. is there any way to check if ignition is on.? cuz with the car off i can still turn the signal lights on. is that normal for that car, i never noticed?? but please help i need the car next week for school.!
 

·
Registered
Joined
·
9,200 Posts
Hello. :) The turn signals shouldn't work with the key off. If it was me, I would charge up the battery with both battery cables disconnected from the battery. Once the battery is charged, re-connect the battery cables, wait 15 or 20 minutes and check to see if the coil feels warm. If yes, the ignition switch is on. :)
 

·
Registered
Joined
·
15 Posts
It does sound like your ignition, try the test suggested by Veronica. If you can't get it fixed before you absolutely need the car for transportation, there's always the "*******" way to get around this problem... Pull the negative battery cable off of the battery everytime you need to leave the car parked. This will at least keep it from draining your battery.
 
1 - 3 of 3 Posts
Top