Ford Mustang Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
A few days ago I replaced my steering wheel rag joint, my tail lights were working before then. Now the tail lights seem to be connected to the emergency flashers because when I have the flashers on the lights on my dashboard light up(constantly when pressed flash when not pressed) but not the tail lights(in either situation). I have voltage go through when the flashers are on but not when they're off. I replaced the brake light switch a week before I replaced the rag joint, so I don't think it's that. I also checked all fuses.

Thank you in advanced, if this wasn't clear I'll try to explain another way.
 

·
Registered
Joined
·
2,095 Posts
In your title you say brake light, but in the story you say tail lights. So please clarify. Did you loosen or move any part of the steering column or shaft inside the car? If so you may have done something to the wires on the turn switch.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
In your title you say brake light, but in the story you say tail lights. So please clarify. Did you loosen or move any part of the steering column or shaft inside the car? If so you may have done something to the wires on the turn switch.
It's the brake lights, they only work for the turn signals. I've checked the wires on the switch and they're connected just fine. But they only have power going through them when the emergency flashers are on. Even then the brake lights don't go on.
 

·
Registered
Joined
·
2,095 Posts
Is it possible you hit one of the harness firewall pass thru connectors? I can't think of anything else in that area to give you this problem.
 
1 - 6 of 6 Posts
Top