Ford Mustang Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
My speedometer bounces and clicks while I drive the car, the odometer does roll over either. Does anyone know how to fix it? i have already put a small amount of white lithium grease on the cable and had no luck....

Thx
Shifty12
 

·
Registered
Joined
·
471 Posts
the odometer does roll over either..

Thx
Shifty12
Have you checked the gear on the end of the speedo cable that plug into the trans :headscratch:. Maybe missing a tooth to two.
 

·
Registered
Joined
·
1,976 Posts
How did you lube the cable? I used a cable luber that I bought at a bicycle store, made to lube brake cables. I use a dry grease spray and the tool forces it down the entire length of the cable until you see it bubble out the opposite end. Good call by *******, probably your main problem though.
Jon
 

·
Registered
Joined
·
1,377 Posts
when I have had a problem with the speedometer jumping it has been because the cable is just about to fail. it has usually been because the inner cable is frayed a bit so it catches as it rotates. if you check your speedometer gear and it is ok, pull the cable and pull the inner cable completely out, check it for frayed areas and if there aren't any then coat the cable with lithium grease and put it back in. I have not seen jonk's technique but it sounds like a good one also. I usually squirt a little carb cleaner down it and blow it out with an air compressor before re-inserting it, but truthfully most of the time when this has happened I have not lubed it in time and I end up replacing the cable. I hope your problem is simpler. either lubrication or a bad speedo gear.
 
1 - 5 of 5 Posts
Top