Ford Mustang Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
34 Posts
Discussion Starter #1
Does anyone have a picture of the reverse light switch installation on a 1969 Mustang 4-speed toploader??

I bought a new switch, as the original was missing and I can't figure out how it mounts. Might I be missing a bracket??

Sincerely!
Sean
 

·
Registered
Joined
·
604 Posts
Does anyone have a picture of the reverse light switch installation on a 1969 Mustang 4-speed toploader??

I bought a new switch, as the original was missing and I can't figure out how it mounts. Might I be missing a bracket??

Sincerely!
Sean
Check out these links:
1969stang.com Mustang Photo Gallery. Stang photos of all year mustangs. 1969, 69, 70, 1970, 2005, GTR. :: stangs-R-me's Deluxe GT Hardtop :: Hurst_T_L_1

Toploader reverse light switch - 1969 Mustang Supersite Web Forums

Jeff
 

·
Registered
Joined
·
34 Posts
Discussion Starter #3
Reverse Light Switch Location

Hi Jeff,

Thanks, but sorry, I should have made clear,, I do not have the Hurst shifter. I have the original ford shift assembly. I can not seem to find any images of this application. I have seen the Hurst.

Sean :rollgrin:
 

·
Registered
Joined
·
1,894 Posts
I'll bet you Mark of Toploader heaven can help you with this.

Call Mark Hammons (580) 229-2856
Home
 

·
Registered
Joined
·
1,894 Posts
Did a little checking. Look at the attached pictures (courtesy of ebay) of a 69 original shifter. Also is a photo of a back up light switch assembly.

Seems obvious to me the switch with the plunger side mounts into the hole in the bracket. the reverse lever arm will contact the switch plunger.

Do you have this switch mounting bracket on your original 69 shifter ?

There is even a support for the cable to be attached to via wire tie.

Make sense to you ?
 

Attachments

·
Registered
Joined
·
15 Posts
I know this is an old thread but I'm having a similar problem. I have a 1970 Mach with a 4speed. My car also didn't have a everse switch so I had to install a new one. I have the correct switch and the little metal retainer but when I install the switch even really the reverse linkage pushes it out of the whole and it doesn't work anymore. Does anyone have any advice or know how to install the switch correctly so it doesn't get pushed out of the whole. Thanks
 
1 - 6 of 6 Posts
Top