Ford Mustang Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
i recently just put in a whole new suspension on my 72 mustang and i drove it for abot 30 minutes and it was running great it wasnt making any noises then all of a sudden it started making a loud squeaking noise when i go over bumps and turn. so when i parked it i got under the car and had my dad push down on the front end and it sounds like the noise is coming from the coil springs. i had heard that when you have the car in the air and you put new coil springs in you need to wait until the car is on the ground to tighten down the 2 nuts on the coil spring mounting bracket i dont know if thats true or not but any oppinions would be great thanks.
 

· Registered
Joined
·
25 Posts
Discussion Starter · #5 ·
alright i checked everything out the coil springs are in right the only thing i didnt replace are the upper control arms and i think thats what is making the noise. the guy who i bought the car from didnt take care of it and didnt really know what he was doing so thats why i bought it because i new it would be a good project car. He didnt put the 90 degree grease zerts in so i went and bought some and when i tried to grease the upper control arms they wouldnt allow grease in and i thought maybe they're seized up and havent been greased in a long time and now they're probably bad.
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top