Ford Mustang Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hi i have a mustang grande 73 and i took it out the other day just down the drive way it shut off and then it had no power to get back up the hill its miss firing really bad. What ive replaced so far is the plug wires new plugs new carb new filter new coil new air filter new distrubtor cap . If someone could help me that would be great thank you
 

·
Registered
Joined
·
12 Posts
Discussion Starter #6
i found a new firing order for the car and it worked except 2 cylinders wont fire but if i press really hard on the wires on the distributor cap they fire. I changed the plug wires and it still does the same thing any suggestions ?
 

·
Registered
Joined
·
2,905 Posts
Hello gunl01,
Not certain what yu mean you found a new firing order
for the motor. Perhaps you were using the wrong one
I don't know.

Here is some advice - -

Determine what motor is in the vehicle. I think "grande's"
came with 351s.
Take a look at this diagram and see if it looks like the firing
order you are using.

Look at the location of the #1 plug wire on the cap.
While looking at the distributor from the front - - the number one plug
is located aprox at 1 o'clock.

Now there are exceptions to EVERY rule depending on wha work has been
done to the motor in the past - - BUT - - we gotta start somewhere.

I would rewire the cap and make CERTAIN that the wires run to the correct
plugs. Study the diagram close. I think it will help.

DO NOT start moving things like the distributor (regulates timing). You will only
cause more issues.

Start simple with the wires and we will go from there.

Print Dad
 

Attachments

1 - 7 of 7 Posts
Top