Ford Mustang Forum banner

1985 Thunderbird, rough idle and hesitation driving

5360 Views 3 Replies 2 Participants Last post by  Masshole
i need some help here if anyone knows....i have a 1985 thunderbird with the 5.0 motor in it....it has the tbi or cfi crap...ok now i have this problem when i drive slowly or not giving it alot of gas it will stumble or sputter then i have to give it more gas then it rides fine ...2 times it stalled on me. sometimes when i come to a stop it will idle very low then catch itself and idle normal again. it almost feels like im running out of gas but i know im not. this is whats new....msd distributer cap, rotor, wires , ignition coil, spark plugs, oil and filter, fuel filter, throttle postioning sensor, coolant temperature sensor, some vaccum hoses, and air charge temperature sensor. so i still have the problem..im thinking either bad map sensor or fuel injectors or fuel pressure regulator..if anyone can please help..also might be the egr positioning sensor..i have no idea its killing me. thanks
Status
Not open for further replies.
1 - 2 of 2 Posts
whats timing and tps set at? Have u reset ur idle?
If u replaced the tps, your setting may be way off...theres a good sticky thread on top of this page that gives you directions on how to set it....whats ur adj fuel reg set at? Remember, whenever you play with a one setting, theres a good chance youll have to play with other settings to get it right. Dont get too frustrated...do a little reading on this site and use the "search" bar on top right of page to help out. It sounds to me like your tps setting is off and your car is starving for air during idle.
1 - 2 of 2 Posts
Status
Not open for further replies.
Top