Ford Mustang Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hello everyone. I have a 1986 ford mustang gt. V8 5.0. It has several mods. Cold air intake, 70mm throttle body and spacer. Msd ignition/coil. It all started with a very bad idle, now in neutral it idles at about 100 to 300 rpms and blows black smoke out of the exhaust. Also sounds really different and weird. It eventually gets to the point where now if I don't keep my foot on the gas it won't stay on. This is a list of things I've done.
1. New CAI filter
2. New fuel filter
3. Fixed all vacuum leaks
4. Replaced spark plug wires
5. Replaced distributor cap and rotor
6. Replaced all intake plenum gasket
7. Cleaned iac valve and replaced gasket
8. Cleaned egr valve and replaced gasket
9. Cleaned throttle body and replaced gasket

I'm leaning towards the fuel pump now but I'm not sure. I've done all this in order to fix this situation with no success. Please help!!!!!!
 

·
Registered
Joined
·
2,057 Posts
I'm not sure what your problem is exactly
but I do know that black smoke indicates
a rich condition. Pull one of the plugs and
if it is black then it is burning rich.
 

·
Registered
Joined
·
672 Posts
Check vacuum to the map sensor or it could be the sensor itself.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
1986 Mustang GT Random idle/stalling PLEASE HELP!

Hello everyone. I have a 1986 ford mustang gt. V8 5.0. It has several mods. Cold air intake, 70mm throttle body and spacer. Msd ignition/coil. Headers and exhaust with no cats. My car runs fine for a while and randomly starts to idle from 100 to 900 rpms and if I don't keep my foot on the gas it eventually shuts off. I need any advice and help I can get. This is a list of things I've done to try to solve it.
1. New CAI filter
2. New fuel filter
3. Fixed all vacuum leaks
4. Replaced spark plug wires
5. Replaced distributor cap and rotor
6. Replaced all intake plenum gasket
7. Cleaned iac valve and replaced gasket
8. Cleaned egr valve and replaced gasket
9. Cleaned throttle body and replaced gasket

I'm leaning towards the fuel pump now but I'm not sure. I've done all this in order to fix this situation with no success. Please help!!!!!!
 

·
Premium Member
Joined
·
6,074 Posts
Welcome to AFM!!

Moved to the 5.0 forum for better response...
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I did some further inspection and noticed one of my injectors under the plenum is leaking fuel. Could that be the problem? I'm planning on changing the o rings on it tomorrow.
 

·
Registered
Joined
·
2,057 Posts
I did some further inspection and noticed one of my injectors under the plenum is leaking fuel. Could that be the problem? I'm planning on changing the o rings on it tomorrow.
I don't think that is it but its a good thing you caught that before it caused a real problem like
a fire. I would check the map sensor like mhuggler
said.
 
1 - 8 of 8 Posts
Top