Ford Mustang Forum banner
Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
I have a 1986 mustang 5.0, that ran great up until about a week ago. I was driving it and i went to rev it up and it bogged way down. If i rev it slow without punching it, it will rev up tp about 3500 rpms. If i punch it it will drowned out and backfire through the intake. With the gas to the floor it will pop and crack but it will not go over 2000. But if you do not punch it it rns great. Also sometimes when i first start it it will rev fine for a few seconds.

I have checked all the vacumes i can find, changed the module on the distributer, put a new coil, put new plugs. I cannot find the problem.

I also took a wire off of a plug and stuck a screwdriver in it, and laid it on the header to make sure the fire was not breaking down when i reved it. From what i saw it done fine. But while i was letting it fire to the header it died. I put the wire back on it and started it and it done good for a few seconds.

I am completely out of ideas. Any suggestions???? THANKS!!!!!
 

·
Registered
Joined
·
842 Posts
Check your fuel pressure
 

·
Registered
Joined
·
46,010 Posts
Sounds like a fuel delivery problem.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
I bought a fuel pressure gauge to ckeck the pressure, but on my 86 it doesnt have the valve. I checked behind the distributer but it is not there. Does anyone know how to check it on an 86?? THANKS! for the posts.
 

·
Registered
Joined
·
71 Posts
Do you have an adjustable regulator behind the upper intake manifold?
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #8 ·
Disregard that last message. I didnt pay atention to what you said. I dont know if it has one behind the intake, i thought you were talking about behind the distributer. What does it look like??
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #9 ·
Good news!!!! I put a fuel pump in it and it fixed the problem.
BAD NEWS!!! It started again after about 20 miles. Idont know if the strainer could be getting stopped up or what. The tank was pretty dirty. How do you flush it out?? Do you just use water??
 

·
Registered
Joined
·
184 Posts
i was havin a similar problem my tank was extremely dirty and my fuel filter would get clogged after just a lil bit check your fuel filter change it drive it and if it does it again drop the tank i cleaned mine with water and ammonia then just let it sit there for like 10 minutes let it dry 4 a lil bit then soaked it with carb cleaner then let it dry out 4 3 days and it works like a charm now :gringreen :bigthumbsup
 

·
Registered
Joined
·
504 Posts
could maybe be a fuel filter...might aswell check the timing...the injectors could maybe b dirty also
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #12 ·
Thanks!!!!

I would just like to thank everybody for their input and answers to my questions. The problem was the tank was dirty and was stopping up the strainer on the bottom of the fuel pump. So i had to clean the tank and put a new strainer on it and it works fine now. THANKS AGAIN!!!!!!
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top