Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello all,

This is the first time I have used this website, and I apologize ahead of time if this information can be found else where.

So I hit a pot hole that jarred my ride, and as I pulled into a gas station and accidently killed it. I tried to restart the engine but no amps.

I popped the hood and notice the Pos battery cable had corred on the post that connects to the solenoid and had broken away from the solenoid. I then replaced the cable and the solenoid. Everything powers up ok but the car will not start.

The car would not start from a jump. I had to push start it to get it home.

I had talked to a mechanic over the phone, and he believes it may be a fuse. I cannot tell from the schematic which fuse position would be the starter.

Also, fuse position 16 pops fuses immediately after being placed. Could this be the problem?

I'm barely getting by, so a mechanic is not an option for now; any help would be appreciated!

Thanks,
-j
 

·
Registered
Joined
·
5,170 Posts
Im an Idiot, lets just say that about my first post.

Fuse 16 is for the Cig lighter, and shouldnt cause your problems.

Make sure the small wire on the Solenoid is getting power, or is hooked up. Should be at the top of the solenoid.
 

·
Registered
Joined
·
46,020 Posts
It must be solenoid related, it could be a fusable link too.
 

·
Registered
Joined
·
37 Posts
for fuse 16 check and make sure there is nothing in the cigarette lighter i had a small metal button get in mine and for the longest time i couldn't figure out why it was blowing. I finally found the button inside it and its perfect now. Sorry i cant answer your actual question but that's what it was for me. Good Luck
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top