Ford Mustang Forum banner
Status
Not open for further replies.
1 - 7 of 7 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter · #1 ·
Hi I have a 1987 Mustang GT 5.0 Convertible, the back side windows wont go up. They will only go done some too, i push the button to have them move and i can hear the side window motors clicking but it must not be catching the windows and pulling them up. Any suggestions on how to fix this? Also sometimes when my car is on the highway and I've been driving around 70 mph it will start to sputter and backfire and i have to pull over and sit for a few minutes and wait then start back up and drive till it does it again. My speed-o-meter is off, its about 10 mph off but when i get to about 45 on the speedometer i checked and I'm actually going 60 mph. Any idea how to fix this? When i turn my lights on it says my brights are on and when i try to turn my brights on nothing happens, also my fog lights dont work. My oil gage and temp. gauge also dont work (thank god the gas one does!) I bought this car thinking it would be a sweet ride and it is, but its my first car, im 19 years old and a little overwhelmed as i dont know a lot about cars or have a lot of money to get them fixed. If you guys can tell me what is wrong or tell me what to look at then my brother in law can fix it he simply doesnt have the time to find out all of the issues, thanks for all your help guys and I hope that you can help me!
 

·
Registered
Joined
·
13,166 Posts
Those gauges suck anyway. If it were me I would just install mech gauges that are accurate. Or you could replace the gauge cluster. The fog lights need to be rewired on a relay, they over heat the wiring which is your problem. If this doesnt fix your bright problem then you need to replace the multi function switch.
Mustang GT Fog Light Fix
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #3 ·
ok sweet ill look into these things right away! lol if you know about anything else I'd love to hear it!
 

·
Registered
Joined
·
13,166 Posts
Sorry I didnt read it very well I guess. You can fix the speedo by removing the bolt that holds the cable in the trans and switching the gear. You will need to know what tire size in rear the gears and what trans you have. You can find the gear by marking the driveshaft (6oclock) and drivers tire (6 oclock). Then turn the tire one full turn and count the driveshaft spins. 1: 3.5 would be 3.55 gears. Then we can figure what speedo gear you need. As for the windows the motors probably need replaced. Do the self tests for the sputtering could just need a good tune up( fuel filter etc).

http://www.shotimes.com/SHO3eeccodes.html
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #5 ·
awesome this is a great start! ill tell my brother in law and get back to you asap! anything else just let me know please! thanks a bunch man!
 

·
Registered
Joined
·
12 Posts
Discussion Starter · #7 ·
yeah im not sure why the car backfires when im going to fast, also it runs very rich! i changed the tps sensor and that helps some but it still runs rich, and ideas for that?
 
1 - 7 of 7 Posts
Status
Not open for further replies.
Top