Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
95 Posts
Discussion Starter #1
ok guys i know its not a stang, but from what i understand engine and trans are the same. just bought the car, only real problem is the automatic doesnt shift right, gets better when it gets warmed up but still off. it sat for almost 4 years, already changed the fluid so im at a loss. 3.8 with an aod i believe, if anyone has ideas i would appreciate the help
 

·
Registered
Joined
·
155 Posts
By changing the fluid after it was sitting, all the old fluid and contaminants in the torque converter washed into the valve body and is causing the shifting problems. That is what the new fluid will do.
In addition the seals may be affected by the new fluid after drying out just sitting. You could try to do another fluid and filter change and it could improve. No guarantee there. Using a little bit (note little) of the Lucas Tranny shift fix might help remedy the problem for now but getting a rebuilt tranny is in the future.

Being an 87 indicates it is about time for a rebuild anyway.


:worshipHail Almighty 2.3L!

You changed the fluid after the problems surfaced? Right?
 

·
Registered
Joined
·
95 Posts
Discussion Starter #3
i changed the fluid a few days after i got the car, its been like this since bbefore i di that. only 112581 miles on it . if it comes to it ive got just about everything i need to throw my t5 in it. couldnt just be a rotted vaccuum line or something? id rather not have to do the 5 speed swap right .ow, but if i did would it be that different from doing one on a stang?
 

·
Registered
Joined
·
95 Posts
Discussion Starter #4
ok so im blind, its fixed now. linkage bar from the throttle was not connected, and i overlooked that lol. like a dream now
 
1 - 4 of 4 Posts
Top