Ford Mustang Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
79 Posts
Discussion Starter · #1 ·
I finally got my stang all ready to hit the street. Everything exept the wipers and the headlights works.

I checked fuses and the headlight fuse was good. The switch is working cause I can still turn on the parking lights.
What gives??


Also,
I got 2 wiper motor relays from the scrapyard and the wipers still wont work...
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #5 ·
its an lx... I think its the wiper/hi beam switch.. looks like its off the the junkyard with me...
 

·
Registered
Joined
·
40 Posts
i accidentally pulled off some wires when taking off my steering wheel and the same thing happened, make sure you take a look behind your steering wheel and check for any wires hanging out of their ports
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #7 ·
got the headlights working with a hi beam/wiper switch replacement... but still no wipers, this is my DD so I reallly need the wipers to work... What could be the problem?
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #8 ·
bump, any ideas? its been raining alot here...
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #10 ·
I just got a multifunction switch, still no bueno...
 

·
Registered
Joined
·
79 Posts
Discussion Starter · #12 ·
I thought about it, but I dont hear a sound when I hit the button to spray fluid either...so that doesn't make sense to me...I guess it couldn't hurt to try...
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top