Ford Mustang Forum banner

Status
Not open for further replies.
1 - 9 of 9 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
what up fellow stangers
here is my issue 88lx new bbk headers h pipe/paxton sn89 supercharger/65mm tb /bbk 255 fuel pump/ported stock lower intake.3.73 gears
ok so i just put the headers on last week no problems.then i got bored and decided to port my lower intake thanks to tom moss by the way. now the cars idle is all over the place surging really good.so i cleaned the iac checked for vacumm leaks/ pcv/reset the tp ajustment disconnected the battery for 20 min. got the car to idle at 800 .but when im driving and stop at a red light it wants to die. my question is am i at the limit for speed density? is the computer unable to handle the xtra air? thanks
 

·
Registered
Joined
·
1,520 Posts
The porting doesnt concern me..but the supercharger may be too much....with all that extra air going to the engine, a SD system pays attention to the fuel, where a MAF would adjust according to the air intake of the engine. Just my 2 cents.
 

·
Registered
Joined
·
2,003 Posts
you need to to get a good tune and maybe a chip. I guess you're using an FMU and it may not be "just right" - the only way to tell is to dyno tune. Porting has zero to do with this problem.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
the supercharger has been on the car for a year and ran awesome. but since i ported the lower intake the other day it`s got issues with surging. im looking for a stock maf system hoping that will fix the issue.when i drive it runs great just at stop lights it dies somtimes and runs rich
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #5 ·
hey tom
great web site!!
yes im running an fmu. i do need a tuning after all the things ive done the "garage mechanic" can only do so much.ill have to set up an appointment at my local mustang guy`s.pj speed shop here in western new york. till then ill go through the entire system for the 50th time.
thanks
ken
 

·
Registered
Joined
·
2,003 Posts
Thanks! Idle problems in SD systems are often due to low vaccum signal - either from vacuum line leaks or low manifold vacuum. Also check your fuel pressure regulator diaphragm to be sure it's not leaking fuel into the vacuum line.
 

·
Registered
Joined
·
175 Posts
sounds like you have a vacum leak
check every thing
 

·
Registered
Joined
·
46,010 Posts
Glad tmoss is helping you out, it sounds like a vacuum issue to me.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #9 ·
you guys were right. after checking it again i found a small leak where my speed density check valve is inline going from upper intake to my map sensor(needed when you have as supercharger on a speed density fox). idle is fine. thanks to all for the help.
ken
 
1 - 9 of 9 Posts
Status
Not open for further replies.
Top