Ford Mustang Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
My 89 GT is pretty much stock I am getting a vibration at 50+ mph only in the front right tire I've checked the ball joints they are tight although I have about a 1/4" play from the arm coming from the rack to the tire is hat normal to have that much play or is my rack taking a crap? When I checked the other side it's tight, it doesn't take a rocket scientist to tell me something is not right there but... Want to make sure that's the problem before shelling out the cash for a new rack

On another note is a Manuel steering rack the way to go if I am to replace it I know they will help cut down on weight but are they street friendly and what goes and stays with the conversion?

Thank you very much for any help
Brian
 

·
Registered
Joined
·
302 Posts
Did you check the balance of the tire? Its also possible the tire is separating, something someone with experience balancing tires should be able to tell you. As far as the rack goes, play is generally a bad thing, but I'm no expert on racks so someone else will have to give you advice on that one, possibly a bad tie rod end or as simple as a loose jam nut
 

·
Registered
Joined
·
44 Posts
Discussion Starter #3
I moved the front tire to the rear and the rear to the front to see if it changed anything and no change still same vibration from right front over 50 seems to get worse in left hand corners, goes away in right hand corners... Weird
 

·
Registered
Joined
·
302 Posts
Ahh now that's a good piece of information. Check your wheel bearing for play. And maybe get someone to wiggle the wheel with hands first on the side, if there's any movement feel the tie rod end, if that's loose that could be your problem and needs to be fixed. If the play is in the wheel bearing then that needs to be fixed. Also get your helper to put his or her hands on the top and bottom, check for play in the ball joint
 
1 - 4 of 4 Posts
Top