Ford Mustang Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter · #1 ·
I have a 89 5.0. Mods are: aluminum heads, rockers, headers, 75MM TB, Fuel pressure regulator, 190 lphr fuel pump, hypertech chip, 373 gears.

My question is my care runs great under normal conditions but when I really get on it and put it to the floor it feels like a sputtering or no power at about 4000 RPM. I notice this a little in 3rd gear but it is really bad in 4th gear. If I let up on the throttle say 3/4 throttle I actually will have more power then if it is all the way to the floor. Also when it bogs down like this I notice white/blue smoke coming out the exhaust and can smell that it is burning oil.

I initially thought it was a lack of fuel problem so I added the bigger fuel pump and changed the filter. This did not help. Engine is not pinging but I decided to try to set my timing from 14 and to about 10 and that did not help. I had put in new plugs and wires when I put my heads on so they are pretty new.

This is a new problem that just started so it is not from the new head install. I also checked my head gasket and that is not the problem. Please Help!!!
 

·
Registered
Joined
·
46,010 Posts
Was that Hypertech chip custom made for that particular combo or an off the shelf version? It could be part of the problem because an off the shelf chip is made for a 100% stock vehicle. You add heads, cam, and so on to a chip meant for a stock application and it may not run right.

What cylinder pressure do they have? Have you done a compression test? And do you have a fuel pressure gauge to see if the pressure is dropping as the revs climb?
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #3 ·
No the chip was not Custom made. I do not think this would be the problem but it is definitely a good point and worth trying.

I have had a compression test ran and it came back fine.
I do not have a fuel pressure gauge that I can view at high RPM. I just check mine by the schrader valve, I have it set to 45lbs.

It is a weird feeling when it happens, almost like a cylinder drops out or something. If it was fuel related why would it burn oil so much then when it happens? I can never smell any oil burn but when this happens you can defintely smell and see it burning oil.
 

·
Registered
Joined
·
109 Posts
Discussion Starter · #4 ·
Any other suggestions?
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top