Ford Mustang Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have an 89 5.0 w/ auto 42K original miles that unfortunately has spent most of its recent life sitting in storage. Hasn't been driven much over the last 10 yrs and none over the past 2. Bringing it back to life now, after first test drive noted the trans is shifting erratically and I'm hearing some new clunk noises. Idle is also much rougher, cleans up nicely revving it over 1500 rpm though.

It has a rear main seal leak, but trans fluid level is OK. Oil and filter has been changed. Haven't done anything else yet other than put a fresh tank of fuel in it. It ran and idled fine when I put it away so this was a bit unexpected.

Car has never been raced or towed anything with it, so I wouldn't consider the trans abused.

Any ideas where to start?
 

·
Registered
Joined
·
508 Posts
:welcomewagon: Welcome to AFM

Try adjusting the TV cable under the throttle body that runs to the side of the trans, it adjusts the shift points. If that is not set properly you will have erratic shifting, The rear main leak is expected for its age, mine leaks too. For help adjusting the TV cable, youtube it, there is a video that explains alot. I had to adjust mine but my trans is for sure trashed but it helped.
I would say as far as the idol, its in dier need of a tune up, plugs, wires, cap, fuel filter, ect. Keep us posted and welcome to the forums
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Is this the cable that runs outboard of the throttle cable? I have a cable that looks like it should connect to the throttle linkage thats just laying underneath....
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top