Ford Mustang Forum banner
Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
180 Posts
Discussion Starter · #1 ·
my speedometer wen i drive does not move at all unless im in 4th going about 60 then it bounces. also my fuel gauge when car is on goes way past full but when off and sits it shows real level i think. but all other gauges work proper wat could be the prob????
 

·
Registered
Joined
·
552 Posts
new motor
new trans
new speedo cable
new gas tank
new rear end
new gauge cluster


start there and let me know how it goes
 

·
Registered
Joined
·
413 Posts
new motor
new trans
new speedo cable
new gas tank
new rear end
new gauge cluster


start there and let me know how it goes
Very good advice...
 

·
Registered
Joined
·
46,010 Posts
Sounds like you need a new speedometer cable, or a new gear for it. I'd look at the gear before buying a new cable to see if it's worn out.
 

·
Registered
Joined
·
180 Posts
Discussion Starter · #6 ·
thanks EAGLE could i possibly get a pic or a lead on locating it
 

·
Registered
Joined
·
1,855 Posts
its on the drivers side of the transmission about mid way on the side of the case you will see the black speedo cable IIRC its a 3/8" bolt that snugs it in remove it and pull the cable out check to see if the gear on the end of the cable is still good not worn down.

if it is you can buy replacements online or from ford for about $6 if that or maybe more
 

·
Registered
Joined
·
180 Posts
Discussion Starter · #8 ·
thanks i was also told it could be my speedometer sensor true?
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top