Ford Mustang Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
Ok so were stumped. I just did a GT40P swap. Includes heads upper and lower intakes and threw an e cam in there. Planned on throwing some power adders on there soon, so we planned on 24lbs injectors w the matching maf. Well what we ended up with were injectors out of a 2004 Mach 1, which are 22lbs? I believe. But the MAF i was sold was for 24lbs. So I grabbed a MAF for a 2004 Mach 1, but it surges like crazy. Throw a stock MAF on you can get it to idle at 850, any lower it starts surging. Also if u literally reverse the position of the MAF it idles perfect (cant run like that cause as so as u rev it up bogs out). Run it with no MAF revs and idle great. Smoke tested it, no vaccum leaks. Timing is bumped up +4*, fuel pressure is set at 39. IM STUMPED
 

·
Registered
Joined
·
200 Posts
Try adjusting the screw on the throttle body, it will not idle when its completely closed, it needs to be open a little for vacuum purpose ...
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
I have been, i literally burned a half tank messing with the idle screw praying to find that sweet spot, but when ever i think i got it, i rev it up and when i let go of the throtal it starts surging! And how much more timing you suggest?
 

·
Registered
Joined
·
1,773 Posts
I have been, i literally burned a half tank messing with the idle screw praying to find that sweet spot, but when ever i think i got it, i rev it up and when i let go of the throtal it starts surging! And how much more timing you suggest?

Check your TPS voltage and adjust.
 

·
Registered
Joined
·
200 Posts
Double check vacuum leaks, behind the intake, between intake and firewall! Is your maf sensor set for your injectors? Check for leaks on TB and upper intake aswell, oh 12° should work on timing,
 

·
Registered
Joined
·
81 Posts
Sometimes when you add a cam to a fox car they don't want to idle right and some idle perfect.I have drilled a hole in the butterfly in the throttle body to get the idle right.Start out with a small bit and go up in size till it idle's right.
 

·
Registered
Joined
·
200 Posts
I've never heard of this! Tell me more? I'm pretty sure opening the tb more with the adjustment screw would be the same, rite?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #10
ok so update. i got pissed at it lol. so i threw the stock injectors and maf on, surging stopped. took it out for a crusie, felt like it started missing under a load. replaced cap coil rotor checked plugs nice burn on em and brand new ford racing 9mm wires. fuel pressure is at 44, timing is at 14. she doesnt wanna b driven :(
 

·
Registered
Joined
·
200 Posts
I'm not a expert on fuel pressure but that sounds like a lot of fuel!! Mine ran about half that at open throttle, do you have a fuel regulator? Mine would idle about 12psi fyi keep us posted.
 

·
Registered
Joined
·
1,773 Posts
I'm not a expert on fuel pressure but that sounds like a lot of fuel!! Mine ran about half that at open throttle, do you have a fuel regulator? Mine would idle about 12psi fyi keep us posted.

12 psi?? Do you have an adjustable regulator? A stock regulator runs about 32 with vac and 38 with vac off.
 

·
Registered
Joined
·
200 Posts
I was wrong! pulled up my video and it looks like idle is at 22 psi and would spike about 32, either way 44 sounds like a lot.. but like I said I'm not a expert on fuel pressure ..
 

·
Registered
Joined
·
10 Posts
Discussion Starter #14
update: well i was fixing the headlight adjustment when i glanced at #1 fuel injector after taking it for a spin n seeing how it was, noticed it was wet, found that the orings were ripped, fixed that, took it for a ride, crusing to clear everything out n see how she ran. im running a c4 w 3:55 so crusing at 65 is like 3500 rpms lol, let off the throtal, car started accelerating by itself. started sh**ing myself. shut it off while still going like 70 and in gear. found the idle screw worked its way in while driving a sh** load, turned it down, turned around, had to repeat this process 3 times to get it back to the shop. starter too a crap from starting it like that. `but no damage to the flexplate or convertor thank god. taking the weekend off to drown myself in some cold beverages :)
 

·
Registered
Joined
·
10 Posts
Discussion Starter #16
Well fixed starter. Locktite the **** outta the starter bolts and throtal screw. Problem solved. No under a load when it's hot it breaks up like crazy. Thinking timing?


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
200 Posts
There is a plug relay your supposed to pull before you can properly set timing, idk the real name for it, just you have to unplug before setting the timing. Go with 12° advanced see if that helps. Top mark on balancer is the one to go by.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #19
Cap rotor Module plugs wires coil all new. Thinking pick up next. Advancing timing and fp try to find right balance?


Sent from my Autoguide iPhone app
 

·
Registered
Joined
·
10 Posts
Discussion Starter #20
Put a known good distributor in. Located air charge temp sensor into intake instead of laying on intake backed some timing out so it's around 17' now fp is 40 wot( Vaccumn line off air idle) switch a few wires around. Cleaned up all ground surfaces. Still breaks up only when your driving for 15+ min, anytime b4 that runs like a raped ape lol. Next guess is fuel gauge while driving. Any suggestions?


Sent from my Autoguide iPhone app
 
1 - 20 of 21 Posts
Top