Ford Mustang Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey everybody, new member but not new to your forums. They have helped me through many mods. I'll try to get my foxbody details posted in what I'm guessing is the signature. But to the point, due to a new busy job and having two kids I (for once) put my stang in a garage to swap my clutch since it had gone bad. He swapped my old stock clutch w a zoom performance clutch, new cable, new throwout bearing, but left the flywheel alone and said it did not need replacing or resurfacing. I get in the car for a test drive and now the entire car shakes when revved. I believe the driveshaft is fine since car speed plays no part in the shaking only engine speed. I believe that somewhere in the assembly is out of balance, but just can't think since I wasn't the one who did it. All ideas are much appreciated! Thanks.
Eli
 
S

·
Guest
Joined
·
0 Posts
Welcome to AFM! Did you tell them about the issue after your test drive? I would make sure they are responsible for their repairs. Let me move this to the 5.0 section for you and get some more eyes on this thread.
Thanks for joining and keep us posted!
:bigthumbsup
 

·
Registered
Joined
·
101 Posts
Is it running on all 8 cylinders?Maybe theres a wire/wires pinched in the bellhousing.Or plug wire fell off/spark plug broke when they had the trans out.I know the o2 ground wires could get pinched.The flywheel is the only thing balanced and if it wasmt off then it should be the right one(50oz).The flywheel should have been resurfaced or replaced to do the job the right way!:nono:
 
1 - 3 of 3 Posts
Top