Ford Mustang Forum banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
99 Posts
Discussion Starter #1
I bought the car about a month ago and the guy told me all the cruise needed was a fuse to work. I have already tried it on the highway and I get nothing. Do any of you know what fuse the cruise runs on and I was also wondering if anyone could help me layout the cruise control system, for all I know some of the components probably arent there or not even hooked up. Im just trying to get some direction to go in to start figuring out why it isnt working before I just start throwing parts at it. Thanks in advance for any help.

1990 Mustang GT
5.0 5 speed
 

·
Registered
Joined
·
4,806 Posts
First of all check to make sure there are two cables under your throttle body. One goes to the interior, the other goes into the drivers fenderwell.
 

·
Registered
Joined
·
99 Posts
Discussion Starter #3
I will check that in the morning, thank you for the quick reply. You wouldnt happen to have a picture of what it "should" look like would you? I also havent been able to find a schematic of the entire fuse box, ive looked everywhere.
 

·
Registered
Joined
·
37 Posts
Check the wires that go to you speedo gear on side of you tranny. IF that is loose then it will cause cuise control not to work.
 

·
Registered
Joined
·
579 Posts
Check Clutch Switch
Check Brake Switch
check for good bulbs in the rear the cruise circuit uses the tail light bulb ground for safety reasons.
Steering wheel switches.
Usually on the Ford Fox the On/Off switch is bad.
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top