Ford Mustang Forum banner

Status
Not open for further replies.
1 - 8 of 8 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
I desperately need help with my 2.3L 1990 Mustang. My turn signals dont work, I have replaced the fuse, and the switch on the column. My hazards still come on and work, but no turnsignals. I cant hear a noise under the dash when I turn them on either. Helppppp!!!!!:confused: :confused:

lodak
 

·
Registered
Joined
·
358 Posts
Clean the grounds and retry.
 

·
Registered
Joined
·
93 Posts
which fuse did you replace? the little one or the big round one? If it was the little one then check your round one it's called a flasher relay. If that dosen't work then you got something else going on and should have the car checked by someone that does electrical.
 

·
Registered
Joined
·
1 Posts
My '91 has two flashers. One easy to find directly under the steering colume and the other hard to find up under the middle section of the dash.
 

·
Registered
Joined
·
3,104 Posts
ixtlan said:
Clean the grounds and retry.
The flasher is the resistence type. Too much and the flasher does not reset...that's what causes the click. Check all the bulbs and make sure all the sockets are clean. Always put grease on the brass part of the bulbs. That displaces air. Air contains moisture and leads to corosion.

Put grease on the glass part and we'll make fun of you. [Insert Smiley]
 

·
Registered
Joined
·
1 Posts
Turn signals don't work - hazards do work

It's the flasher unit. Here's the kicker... Aaaargghh! I can't get to it under the dash! I have the part in my hand to make the replacement, and the spot that looks like the most likely candidate from the Chilton's manual is encased on a metal cover that I can't separate from the dash suspension.... Any ideas? Has anyone replaced a flasher?
 
1 - 8 of 8 Posts
Status
Not open for further replies.
Top