Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
315 Posts
Discussion Starter #1
So i was driving on the freeway at 65ish and all of a sudden the rpms drop to 0 and i slowly decelerate because the gas pedal was doing nothing. It dies when i pull over but then fires right back up. I continued driving around 45ish and sometimes the rpms would drop like 200-300 then shoot back up causing it to sort of jump. I got it to my mechanic to put in a new fuel pump and he said there is a leak in the gas tank. Could this be causing it? Or anyhone know what it might be?
 

·
Registered
Joined
·
315 Posts
Discussion Starter #3
Alright ill look into those. I was thinking maybe it was something to do with the maf or fuel related
 

·
Registered
Joined
·
46,020 Posts
Have him check the output coming from the distributor, when the pickup fails it'll cause the engine to just shut off like someone turned the key. If it's not totally shot, it'll let the engine fire right back up. A sign of it is if the tach jumps around when you try to crank it.
 

·
Registered
Joined
·
315 Posts
Discussion Starter #5
Just had the distributor and tfi module changed bout a month ago because i was having those problems. This feels different though because it doesnt die. The rpms drop to zero and no matter how much gas you give it, it continues to decelerate. It then dies when you stop. Also when i drove it home today, it did it bout 2 times again on the freeway but this time white/grayish smoke came out the exhaust...Im lost. Any ideas
 

·
Registered
Joined
·
315 Posts
Discussion Starter #6
Bump...
Any ideas. Ive been researching and cant find anything that would cause the rpms to drop to zero and the car to remain running:headscratch:
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top