Ford Mustang Forum banner

Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
Here goes. My tach wire shorted to ground and killed my coil. I've replaced the coil, TFI module, and now the ECU (thought it was bad).

The relay is still not working, if I bypass it the fuel pump works fine. All of the fused links under the hood are good.

Where else do I need to look??:headscratch:
 

·
Registered
Joined
·
46,020 Posts
Did you try the EEC power relay yet? It's what sends power to the fuel pump relay. It should be close to the ECU and look just like the fuel relay.
 

·
Registered
Joined
·
70 Posts
Your title says Fuel Pump relay, which is under the driver's seat in my '91 convertible. On mine, it wasn't the relay that was bad, but it was the plug into the relay. Cost me $11 and I had to splice 4 wires to get it in.
 

·
Registered
Joined
·
44 Posts
Discussion Starter #4
Found the problem!!!!

:scratchchin I should have been more clear when I posted... Everything cycles fine, when you turn the key to run, the fuel pump does not prime. It does work if I bypass it, thats why I said fuel pump relay not working.

I checked all of the fusible links at the starter relay, these were good. I talked to a few buddies and it was suggested that another link was gone. I looked in mt electrical & Vac trouble shooting book, and noticed there was a fusible link near the brake booster. SNEAK for one to be there, I didnt even notice it at first, the only thing that gave it away was a bubble on one wire and there was some powder on the harness.

Here is the culprit, aparently when I pulled the cluster forward the whire chaffed and eventually shorted, the coil to chassis ground.


here is the harness going to the EEC, and the fusible link after I unwrapped it from the main harness.


close up of the bubble that I noticed & eventually traced back.



I replaced it with a 5A fuse, I tried a 2A and it didnt last long. SOOOO after all that I wrapped up my dash, double checked it a few times :happyhapp (the dash will have to come apart one more time after my guage is repaired)

I have to reset the idle, because I changed the idle rpm in the BIN:so and hopefully I can start to put some miles on my motor & trans.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top