Ford Mustang Forum banner
Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
Just put my 3.73's in. Very enjoyable! Car seems a little sluggish of the start. Smells a little rich also. With in the last year I have put a new O2 sensor in, new tps which is set at .85, EGR sensor, IAC valve, complete tune up with K & N filter, removed air silencer, cleaned and tested the MAF. Timing at 14. Is it because it is an aod or am I missing something? I just feel I should be put in the seat a little more.
 

·
Registered
Joined
·
1,520 Posts
tps too low...should be .98
 

·
Registered
Joined
·
186 Posts
i don't think that the tps setting being at .85 would make that much of a difference because even from a stop when you punch the throttle wide open the tps is going to read over 2 volts.
 

·
Registered
Joined
·
46,010 Posts
It's probably the AOD and it's 1200 stall speed converter. If you were to swap in a shift kit and a 2200-2400 converter it'd be a night and day difference.
 

·
Registered
Joined
·
152 Posts
Hi,A buddy of mine has a 93gt with aod and it is sluggish off the line also.he has more mods then me but my 5spd murders his car from a dig.If we go from a roll he pulls me by half a car through 4th gear then after that he keeps going while I sit there in 5th.Do what Eagle said and you will love it.
 

·
Registered
Joined
·
107 Posts
damn i just rebuilt my aod with a transgo shiftkit and i have the same thing.
i checked timing(off by three degrees,dont know if that makes a difference)cleaned MAF,checked tps.
didnt think a stall converter would make that difference
my buddy did the same to his and he did put a 2500 stall in it today
ill see how his is and i will post back
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top