Ford Mustang Forum banner

Status
Not open for further replies.
1 - 20 of 27 Posts

·
Registered
Joined
·
711 Posts
Discussion Starter #1
I went to the junk yard yesterday and got a computer out of a 93 mustang 2.3 auto. Same numbers and all. Put it in. I found out the starter went bad so I bought another one. It will try to crank over but still no start. I now have no fuel at the rails so I am going to attempt to put in the 5.0 fuel pump. If it don't work can I put an aftermarket pump on with it? I seen one at advance auto for $40. How do I hook it up? Can I put it on with a non working pump or do both pumps need to work?
 

·
Registered
Joined
·
91 Posts
whoa whoa slow down....

1st lets start here... why did you change your computer?
Don't blame the computer right away.. the jy might be no good 2...
Now for the fuel pump... when you put your car into accessory... Do you hear your fuel pumps prime? and when you start it does your fuel relay click on?
If it is completely slient check all your fuses in the fuse box the fuel pump has a fuse and also check your fuel pump relay for power... I hope this helps you out.. let me know what you find
 

·
Registered
Joined
·
711 Posts
Discussion Starter #3
whoa whoa slow down....

1st lets start here... why did you change your computer?
Don't blame the computer right away.. the jy might be no good 2...
Now for the fuel pump... when you put your car into accessory... Do you hear your fuel pumps prime? and when you start it does your fuel relay click on?
If it is completely slient check all your fuses in the fuse box the fuel pump has a fuse and also check your fuel pump relay for power... I hope this helps you out.. let me know what you find

Where is the fuel pump relay for a DIS 93 foxbody? I can't find it. Some one told me it might be the computer only because I ran 17lb injectors from a 3.1l Grand Prix. Now before I take down the tank i'd like to check the relay but can't find it. The pump makes no humming noise.
 

·
Registered
Joined
·
91 Posts
on 92-93 and I think the fuel pump relay is in the (IRCM) Integrated Relay Control Module that is located on the passeger strut tower in the engine compartment. It looks like a computer. There are 4 relays in there together and they are not replaceable. You have to get a whole new unit from Fordor go to a junk yard and pull one. For a '93 it must be from a '93 and some late 92's have it 2

hope that helps you further.... were all the fuses good?
 

·
Registered
Joined
·
711 Posts
Discussion Starter #5
gonna check the fuses and see if I have power to the pump with a test light. I just poke the test light into the power wire to the pump right? It's been awhile.
 

·
Registered
Joined
·
91 Posts
just see if the fuses are good to start lol.... you know I don't remember either.... but did you try putting the stock injectors back in... could be the injectors ...
 

·
Registered
Joined
·
711 Posts
Discussion Starter #7
Yes. I put them back in. I'm never changing those again. Lol. Fuses are all good, I hear the relay clicking (after I beat it up lol) and I hear the fuel pump prime but with the key in the on position I got less pressure than a water bubbler. It should be the pump right?
 

·
Registered
Joined
·
91 Posts
what do you mean by beat it up? How much gas is in the car?
 

·
Registered
Joined
·
711 Posts
Discussion Starter #9
hit the icrm with a wrench like you do to the starter or other relays. If I put the key in the on position and let it prime and the pressure is low, is it the pump or not?
 

·
Registered
Joined
·
711 Posts
Discussion Starter #10
I changed the fuel pump with a 5.0 pump I got from the yard when I got the injectors. Same thing, no fuel to the rail. I hear the relays clicking when the car is being started. I also hear the fuel pump priming. Now what?
 

·
Registered
Joined
·
91 Posts
1st i would go back to the yard and get the icrm start there...
 

·
Registered
Joined
·
711 Posts
Discussion Starter #12
I'll try but it doesn't show up on my code reader and I hear it clicking when I turn the key and do a scan.
 

·
Registered
Joined
·
91 Posts
well if you had to wack it to get it to work something else is wrong... which could mean it is not working correctly
 

·
Registered
Joined
·
711 Posts
Discussion Starter #14
But I keep wacking it and nothing. Which wires are for the fuel pump relay on that thing? I'll rip out the wires and replace the relay with a little box relay.
 

·
Registered
Joined
·
91 Posts
there are 3 or 4 relays in that box together... you have to replace the box that is why i say to get the other one... it works a lot of other things in your car... I do not have a wiring dgram can't help u there... sorry
 

·
Registered
Joined
·
711 Posts
Discussion Starter #16
I'll try.:bigthumbsup
 

·
Registered
Joined
·
711 Posts
Discussion Starter #17
O.k. I went to the yard and got 2 from 1993 2.3l auto's. One was just bought or manufactured in 2005. The parts numbers match but the one's I got from the yard are AB, mine is AA. Does it matter? Why are the last 2 letters different but come from the same year? Now it sounds more like it wants to start but when I took the tank down it barely had gas in it. Like maybe a cup or less. What else can it be? Can't the car run on fumes or is that a saying. AAARRGGGGGGG!!!!!!
 

·
Registered
Joined
·
711 Posts
Discussion Starter #18
O.k. I went to the yard and got 2 IRCM from 1993 2.3l auto's. One was just bought or manufactured in 2008. The parts numbers match but the one's I got from the yard are AB, mine is AA. Does it matter? Why are the last 2 letters different but come from the same year? Now it sounds more like it wants to start but it still don't. When I took the tank down it barely had gas in it. Like maybe a cup or less. What else can it be? Can't the car run on fumes or is that a saying. AAARRGGGGGGG!!!!!!

That's more like it.:oops:^
 

·
Registered
Joined
·
91 Posts
fill up your gas tank with gas... sounds like you have no gas... as for it being ab instead of AA that means it is a newer better parts design... good find
 

·
Registered
Joined
·
711 Posts
Discussion Starter #20
fill up your gas tank with gas... sounds like you have no gas... as for it being ab instead of AA that means it is a newer better parts design... good find

I have another one if needed. But yeah I put $7 in it and it took some time but it started. Now it clicks real loud.
 
1 - 20 of 27 Posts
Status
Not open for further replies.
Top