Ford Mustang Forum banner

Status
Not open for further replies.
1 - 13 of 13 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
I am open to any suggestions or advise. Anything that can point me in the right direction so I can begin trouble shooting and hopefully resolve the issue without breaking my wallet!

I have a 1994 V6 3.8 beauty. It has a brand new motor (only 63,000km on it). Basically, the car runs great except the transmission...sometimes. I had a brand new valve body installed, as well as a transmission cooler. It seems to slip more when it gets heated. The transmission cooler made a difference which is nice, but it still slips.

It has difficulty catching gears sometimes, it will rev up to 2500-3500RPM then when it catches, it jolts the car a bit (usually after letting off the gas...I don't want to blow the motor). Sometimes (especially in heavy traffic) I can place it in 2nd and it does just fine. Going up hills, hitting the freeway, alot of stop-go traffic conditions causes it to slip. The O/D light was flashing for a while but stopped after we unplugged the battery to do other unrelated maintenance.

Any advise is greatly appreciated! Thank you!
 

·
Registered
Joined
·
1,544 Posts
What do you mean it slips? Our stock tranny's shift slowly, so it may seem like it's hovering between gears... Really, the fluid in the tranny is just flowing from one section of the valve-body to the next and slowly engaging the next gear.

And I'm curious about the valve-body: was it a jmodded one (aka - with a shift kit)? :scratchchin Jmod basically opens up the paths in the valve-body, so that the fluid can flow faster. That will make your tranny shift much faster/harder, so it can seem like the car is jolting...

And you talk about 2500-3500rpm... mine redlines at like 4000rpm: are you letting the car finish the gears? What I mean is, do you ever just hold the gas pedal down all the way and just let it shift itself through the gears? Your car should wind up to 4000rpm, pause to change gears, and then continue in the next gear, and so on... Letting off the gas suddenly isn't bad, but it may cause a sensation of the engine bogging down...

As far as hills and city traffic: turn off the O/D! :bigthumbsup When the overdrive is on (default: when you turn on the car, it is on!), the computer tries to shift into the highest gear (lowest rpm) as soon as it the torque is low. Your auto tranny will be changing gears faster than woman change their shoes! ;) Instead, if you press the button on your stick and turn off overdrive (and the little green light comes on), your car will keep revving if your at WOT, and upshift a little later if you're not. And it won't go into 4th (O/D) gear unless your speed (100+) dictates the use of it. :D

Sorry to be long-winded, but maybe if you're more specific - I can be more specific in my answer! :shigrin
 

·
Registered
Joined
·
9 Posts
Discussion Starter #3
Hey thanks for replying! Yeah I know that the RPMS can handle 4000-5000...But I believe my transmission is slipping into neutral. I allow it to go through the gears, then when it hits 3rd gear (for example) I COULD keep my foot on the gas and let it rev its heart out...but im not really moving anywhere LoL. It will eventually hook up and off I go with a jolt forward, somtimes it does this twice. I really dont want it revving too much (especially if im not going anywhere, I dont want to blow the new motor, i know it would take alot of abuse to actually blow it city driving....but its my babe :)

The valve body was replaced because it was garbage. I will assume they replaced it with another stock Ford one (I will double check on that though).

Thanks for the advise on the O/D. I know what O/D is but I have been driving a crazy quick japanese car for the past few years and the transition takes some getting used to.

My biggest question is, is there a possibility that this could be some sort of a sensor? I had it parked for a long time then once I had it mechanics were all over it. Im wondering if maybe my car is confused? or its not sure how fast its actually going and wants to adjust the transmission?
 

·
Registered
Joined
·
9 Posts
Discussion Starter #4
Oh and the transmission was rebuilt a few years ago. Worst case scenario, some idiot put one of the gears in backwards.
 

·
Registered
Joined
·
1,544 Posts
Hey thanks for replying! Yeah I know that the RPMS can handle 4000-5000...But I believe my transmission is slipping into neutral. I allow it to go through the gears, then when it hits 3rd gear (for example) I COULD keep my foot on the gas and let it rev its heart out...but im not really moving anywhere LoL. It will eventually hook up and off I go with a jolt forward, somtimes it does this twice. I really dont want it revving too much (especially if im not going anywhere, I dont want to blow the new motor, i know it would take alot of abuse to actually blow it city driving....but its my babe :)
This makes me think it might be the torque converter... but I'm no expert on trannys, so it's just a guess. :so
The valve body was replaced because it was garbage. I will assume they replaced it with another stock Ford one (I will double check on that though).
Yeah, probably not the issue. Even if they gave you a modded one, it would help the shifting - the opposite of what you're feeling...
Thanks for the advise on the O/D. I know what O/D is but I have been driving a crazy quick japanese car for the past few years and the transition takes some getting used to.
Haha! :laugh: No worries - you'll figure her out. BTW - what "quick japanese car" did ya have? :scratchchin
My biggest question is, is there a possibility that this could be some sort of a sensor? I had it parked for a long time then once I had it mechanics were all over it. Im wondering if maybe my car is confused? or its not sure how fast its actually going and wants to adjust the transmission?
At this point, I would take it to a tranny shop to have them look at it... Like I said, I'm no expert - sorry. :embarrassed But you can also check out this site; there's LOTS of info on our trannys (specifically see "Ford OD Transmissions 101"): TCCoA Tech Articles#
 

·
Registered
Joined
·
9 Posts
Discussion Starter #6
Yeah I found ALOT of information just cruising through the rest of the site. I used to drive a 03 Suzuki Aerio (fully loaded AWD)....LoL Mostly older people or younger people with families have those, but DAMN that thing could move! (its like a big bike engine in a super lightweight car) Its super low to the ground and has awesome suspension, it would have made a wonderful (but stupid looking) rally car. :hihi: Its my moms car now. :bigthumbsup
 

·
Registered
Joined
·
1,544 Posts
Yeah - it's kinda like minivans: unloaded, they are pretty powerful. :shigrin And you can't argue with AWD when you live in the north... (that's why my wife has a Subi WRX) :D But, I googled some picks of it... and it's not quite my style :happyhapp And that's probably the same reason you gave it to your mom! :laugh:

Anyways, did you get your tranny problem checked out? What's the latest? :scratchchin
 

·
Registered
Joined
·
9 Posts
Discussion Starter #8
Well I have decided that my car is a schizophrenic :p. I slips out when it wants, other days its a dream to drive. Recently, it has been a bit worse than normal.

I fueled it up one day and when I turned the car back on, the check engine light came on. There is nothing wrong with the engine, but it can come on when it wants you to pull codes off of it. The O/D Off light blinks on and off when it wants to also.

Im taking it to a transmission place tomorrow, for full diagnostics as well as a road tests. Chances are my car will act like a little angel and I will once again be told that nothing is wrong LoL. I hope thats not the case, I NEED it to act like an idiot so I can get this problem solved, hopefully in time for a big camping trip coming up in a few weeks.

Other than that I have brand new carpet waiting to be put in, side skirts for my dual side exhaust to be put on and im getting new headlights because the stock ones are looking pretty yellowish and weird...plus new ones will look bad ass!

P.S. I LOVE Subaru's! If I didnt have my Mustang I would probably own a Subaru :bigthumbsup A guy I worked with has a 2003 WRX STI and it was some kind of fast!

Oh if you havent seen this already, you and your wife have to watch it! http://www.youtube.com/watch?v=0s_s8bylne0
 

·
Registered
Joined
·
1,544 Posts
I don't know why I didn't suggest this earlier: when was the last time you got the tranny flushed? Not just a filter change, but the full system flush? This will help your tranny all-around. (speaking of... I need to get one soon! :happyhapp)

Also, you mentioned your car sat for a while... so maybe it reset the ECU. When you disconnect power for long enough, you can atcually reset your ECU. So it goes back to the default of gas-saving mode, so it will control the tranny differently - unless you drive different and retrain it! When I installed my CAI, the instructions said to disconnect the battery overnight (to drain the power and reset the ECU). Then, it updated the MAF reading to match the increased air flow/density. Also, I stomped on it every chance I could, so I trained the ECU to shift later. So long story short, try disconnecting the positive lead on your battery overnight to reset the ECU.

On the other hand, your upgrades sound nice! :shigrin Where'd you get the side exhaust from? Did you use an adapter and a GT kit, cuz I didn't know they made side exhaust kits for the 6... Headlights are a great idea - I love mine (obviously - look at my avatar! ;))! Post pics when you get the stuff done! :bigthumbsup

And yeah, modded Subies are pretty hot - especially the sound of those Boxer engines! Probably the best sound ricer engine out there... :laugh: I have to take the Evo for looks, though (especially the new ones, the Xs!!) Couldn't see the vid... but I'll keep trying.

Anyways, lemme know what the tranny shop finds out. Good luck!
 

·
Registered
Joined
·
178 Posts
Silver J, what did your headlights cost you? I love that look, think it should go nicely with a '95??? :bigthumbsup
 

·
Registered
Joined
·
1,196 Posts
i vote, check ur tranny fluid, if it is low dont just put a regular quart of tranny fluid in it, put some Lucas Transmission Stop Slip fluid in it, i swear it really does work... so dont all the Lucas oil products minus the fuel injector cleaner....
 

·
Registered
Joined
·
1,544 Posts
Silver J, what did your headlights cost you? I love that look, think it should go nicely with a '95??? :bigthumbsup
Of course it will go nicely - same body style as mine! ;) :shigrin I got them for $220, shipped, from MrBodykit.com. Check it out - they have a bunch of different choices! :bigthumbsup

And now we return to your regularly scheduled program... :laugh:
:backontopic:
 

·
Registered
Joined
·
9 Posts
Discussion Starter #13
Well I was laid off about a month ago so I dont have alot of money to fix my car these days.

When I had the new valvue body put in they did a full tranny flush. After alot of trial and error trying to fix the tranny we now know (90% sure) its mechanical. BUT there is also something funky going on with the computer. There is just so many things that could be wrong with my car, I love it so much but it stresses me out to the max.

I bought some new headlights (finally LoL). I dont know the exact name or brand but they are smoked. They look really clean and badass.

I have Borla duel side exhaust :D It sounds amazing I love them. I know that it was a custom weld job but once they were in they fit like a glove.

Honestly, my car is driving me nuts LoL This morning it wouldnt even start (its not dead though). The ACC sounded normal ( I can hear the fuel pump, normal beeping sounds ) then when I tried to fire him up I heard a loud rapid ticking sound and my alarm system beeping quietly. It has a brand new battery and altenator, plugs etc (like I said earlier its literally a brand new engine) So my bf thinks the starter is screwed.:headscratch:
 
1 - 13 of 13 Posts
Status
Not open for further replies.
Top