Ford Mustang Forum banner

Status
Not open for further replies.
1 - 6 of 6 Posts

·
Registered
Joined
·
1,089 Posts
Discussion Starter #1
Well i just bought this 94 5.0 stang its a 5spd. well the only other 5.0 i have been in was my buddys fully stock automatic he had for 4 years. well his was slow in HP but had so much more torque than my 5.0 why is this?



This 5.0 has straight pipe exhaust,big ass intake manifold not sure which one? and 70mm BBK power plus throttle body. and roller rocker arms.

So when im getting on it i feel it push me back good untill 3800RPMs and above i feel like all the torque dissapears and loses power untill i shift. why is this? and the torque isn't as strong as my buddys.


The only thing i know wrong with it is a exhaust leak at the passenger side headers and the fuel pump isn't getting its fullest amount of power.
 

·
Registered
Joined
·
1,089 Posts
Discussion Starter #3
Will that help? cause my buddys newly built 5.0 also lost power above 3800 RPMs. we thought it was cause it was stock.
 

·
Registered
Joined
·
552 Posts
your givin a stock 5.0 to much credit

170 hp to the wheels boss man :bigthumbsup

thow sum h/c/i on that *****!!!
 

·
Registered
Joined
·
1,089 Posts
Discussion Starter #5
ya maybe ^^^ just comparing it to my buddys 5.0 that was completely stock on a auto tranny. mine has intake and throttle body so i expected a bit more.
 

·
Registered
Joined
·
1,089 Posts
Discussion Starter #6
Well It feels sort of weak on torque but i guess im wrong cause i did a 2nd gear burnout earlier and it could had went to 3rd if i would had tried. so it is powerfull but like when im going straight and i hit 1st and 2d gear it dont pin me back it just picks up speed fast but without pining me. my buddys 5.0 would do the oppsoiste pin you but go no where.
 
1 - 6 of 6 Posts
Status
Not open for further replies.
Top