Ford Mustang Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
I check the belt on my brother's 95 Mustang 5.0 and it was broken. I checked the belt and noticed that it was burnt on one side. What could've caused this problem? I never had any experience when it comes to fixing cars.
 

·
Registered
Joined
·
1,068 Posts
Usually when a belt looks like has "burned" it's from an accessory freezing up so that the pulley won't turn...the belt continues to spin and just shreds on the locked up pulley. A/C compressors locking up are the most common cause I've seen. Water pump could possibly do it.

Just make sure that all the pulleys spin freely when you put the new belt on and start the car. It's possible the old one was just extremely old.
 

·
Registered
Joined
·
5,170 Posts
A/C compressor or smog pump are the top 2 that lock up. Try spinning all the pulleys by hand.
 

·
Registered
Joined
·
1,068 Posts
Can all pulleys be spun by hand or only certain ones?
Not sure if power steering can be...probably. I don't know about the smog pump either...I don't have a car with that still on there. Others should be able too. I'd say check when the car is running...that will show you, period, if any are locked up under normal conditions...especially if you turn the A/C on.

Obviously you don't need to try the crank pulley.
 

·
Registered
Joined
·
1,068 Posts
That is an ok belt. I'm just using Gates belts on mine. They work.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #8
I had time to check which pulley is broken today and its the smog pulley. I'll buy a shorter belt just to get the car up and running.
 
1 - 8 of 8 Posts
Top