Ford Mustang Forum banner
Status
Not open for further replies.
1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter · #1 ·
Hey hopefully someone can help me get to the bottom of this. I have a V6 1995 Mustang. I have a flowmaster exhaust with an h pipe on it. I also have a K&N intake in it. Right now since i put the K&N filter on the check engine light is on. It's always had relatively bad gas milage too(17 in town and 24 on the highway). Before i bought it the engine was changed at 80,000 miles and it now has 120,000 on it. When i first start it up the rpms will drop and almost cut out. Then it recovers and idles fine. If I'm at a stop sign and give it some gas it hesitates a lot. Its like i didn't push the peddle down then it picks up again. I'm just not real sure where to start. I am thinking it could be my fuel filter and I'm going to change that tomorrow. Anyone have any ideas.
 

·
Super Moderator
Joined
·
40,152 Posts
welcome to the site,enjoy!!!! a fuel filter change is good.do you have any codes? check the iac.see if it is dirty also.
 

·
Registered
Joined
·
8 Posts
Discussion Starter · #3 ·
I went to Auto Zone and had them read the codes. There was three that popped up. P0102-The PCM has determined that the mass air flow input is lower than expected for the current engine operating conditions
P0174-The PCM has determined that during testing, the fuel system for bank 2 was too lean.
P0171-The PCM has determined that during testing, the fuel system for bank 1 was too lean.
The guy wasn't too much help, all he said was maybe change the O2 sensor.
 

·
Registered
Joined
·
40 Posts
My 95 V6 has the exactly the same problem last year. I did buy a new MAF for $99 at Kragen Auto Parts. It solved the problem and been running good till now.
 
1 - 4 of 4 Posts
Status
Not open for further replies.
Top